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1 QUICK START 
1.1 What is PEAXACT? 

PEAXACT is a comprehensive Windows application for the quantitative analysis of spectroscopic 
data using several state-of-the-art and innovative chemometric analysis methods. PEAXACT 
contains interactive tools for data visualization, exploration, modeling, classification, and 
calibration to identify and predict features from unknown samples. It offers quick-and-easy 
access to established methods like Peak Integration or Partial-Least-Squares and is the only 
software product that provides innovative Spectral Hard Modeling methods. 

Separation to Related Software Products 

PEAXACT is a Windows desktop application for interactive use. It is complemented by two related 
products, PEAXACT ProcessLink and PEAXACT AppServer, for the automated use in process 
analytics and reaction monitoring. 
 
PEAXACT is optimized for spectroscopic data, e.g., IR, Raman, UV-Vis, and NMR spectra, but can 
be used for all kinds of peak-shaped signals in general. PEAXACT strongly focuses on quantitative 
data evaluation, i.e., determination of numerical properties from measured samples, though it 
also provides classification methods, i.e., determination of categorical properties. 
 
PEAXACT does not ship with a spectral database for the identification of unknown substances 
from measured spectra. However, users can create their own database and train a Classification 
Model to achieve this functionality. 
 
PEAXACT does not replace operating software for spectrometers. PEAXACT rather operates on 
data measured and saved with such software; it supports various third-party file formats. 
 
PEAXACT is equipped with several data analysis methods. Some of these methods may also be 
distributed with other software. However, unique hard modeling methods like Indirect Hard 
Modeling (IHM) and Hard Modeling Factor Analysis (HMFA) are available in PEAXACT only. 

1.2 Getting Help 

User Manual 

This user manual documents a certain version of PEAXACT. You can find the version number and 
release date on the title page. 
 
We are continuously working on improving the manual. The latest document version is 
distributed as PDF file with each PEAXACT software update. The file is in subdirectory Help of the 
PEAXACT installation directory. 
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Technical Support 

S-PACT Technical Support can be contacted in different ways: 

• E-mail to support@s-pact.com 

• Web form at www.s-pact.com/support 

• From the PEAXACT main window (see Request Support) 

Note: A subscription of S-PACT Software Maintenance Service (SMS) is required to be 
eligible for technical support. The first year of SMS is included with new PEAXACT 
product licenses. 

Blog 

The PEAXACT Blog was launched as a free source of information complementary to the user 
manual. It contains tutorials and tips & tricks. See: blog.peaxact.com 

1.3 Installation & License Activation 
1.3.1 Requirements 

• 64-bit version of Microsoft Windows 7 SP1 or Windows 10 

• Any Intel or AMD x64 processor (four logical cores and AVX2 instruction set 
recommended) 

• 5 GB of disk space (10 GB recommended) 

• 4 GB RAM (8 GB recommended) 

• No specific graphics card is required. Hardware accelerated graphics card supporting 
OpenGL 3.3 with 1GB GPU memory is recommended. 

1.3.2 Licensing 

PEAXACT software is furnished under a license agreement. The software may be used only under 
the terms of the license agreement. 
 
License conditions vary with respect to license type, license option, and license modules. This 
section only gives a short overview of the different license options. For the full and legally valid 
conditions please refer to the license agreement document. 

Note: Depending on the modules of your license, you may not be able to access all 
PEAXACT features. 

License Options 

Individual PEAXACT can be installed and operated by a single designated 
named user on up to 2 designated computers. 

mailto:support@s-pact.com
http://www.s-pact.com/support
https://blog.peaxact.com/
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Group PEAXACT can be installed on a specified number of computers and 
can be operated by an unlimited group of users (one user per 
computer at a time). 

Network PEAXACT can be installed on any number of computers in a network 
and can be operated by a specified number of users simultaneously. 
Licenses are shared among all network users. This option requires 
the PEAXACT License Server. 

1.3.3 Installation 

Step 1: Before You Install 

• Make sure your computer fulfills the system requirements. 

• When upgrading an existing installation, visit www.peaxact.com/whatsnew and read the 
upgrade notes and compatibility considerations. 

• Make sure you have administrator privileges to perform the installation. 

• Make sure your license is valid for the major version number. If you do not have a license 
yet you can get a free trial license or purchase a license after installation. 

Step 2: Install PEAXACT 

• Download the PEAXACT Installer from www.peaxact.com/download 

Note: The installer's file name is PeaxactInstaller_<major>.<minor>_win64.exe. 
Different major versions can be installed side-by-side, e.g., versions 5 and 4. The 
installer upgrades earlier installations of the same major version. 

Online Installation 

• Run the PEAXACT Installer and follow the setup instructions. Additional runtime packages 
are downloaded and installed automatically if detected missing. 

Offline Installation 

• If you are planning to install PEAXACT on a computer without internet access, you must 
download additional runtime packages in advance from 
www.peaxact.com/runtime 

• Save all installer files to a folder on a portable drive. Do not rename files. 

• At the offline computer, run the PEAXACT Installer and follow the setup instructions. 
Runtime packages are installed automatically if detected missing. 

Step 3: After Installation 

• After a new product installation continue with License Activation. 

• After upgrading an existing installation check the upgrade notes at  
www.peaxact.com/whatsnew for further upgrade steps. 

http://www.peaxact.com/whatsnew
http://www.peaxact.com/download
http://www.peaxact.com/runtime
http://www.peaxact.com/whatsnew
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1.3.4 License Activation 

Note: A license access code may be required for activation. Codes are provided to end-
users or designated license administrators after a license purchase or trial request. 
Note: If you perform the activation with administrator privileges, licenses will be 
activated per-machine, i.e., for all Windows users. Otherwise, licenses will be activated 
per-user, i.e., for the logged-on user. Per-machine takes precedence over per-user. 

Select PEAXACT 5 > Activate PEAXACT from the Windows start menu to open the  
License Activation Dialog. Then select the PEAXACT Desktop App product. 

Online Activation 

To activate PEAXACT over the internet: 

• Select Download License… from the drop-down list. 

 

• Enter your license access code and click OK. Then close the dialog. 

Offline Activation 

To activate PEAXACT on a computer without internet you must download the license using 
another device. 

• Make a note of the Host ID displayed in the License Activation Dialog. 

  

• On a device with internet, visit www.peaxact.com/activate. 

http://www.peaxact.com/activate


1 - QUICK START 8 

S o l u t i o n s  f o r  P r o c e s s  A n a l y t i c s  &  C o n t r o l  T e c h n o l o g y  

• Sign in to the License Center with your license access code. 

 

• Enter a description (e.g., the computer name) and the Host ID, then click Add. 

• Click Download license and save the license file to a portable device. 

• In the License Activation Dialog, select Import License… and load the license file. Then 
close the dialog. 

Network Activation 

To activate PEAXACT over the local network, the PEAXACT License Server must be running on a 
server computer. 

• Select Check-out from License Server… (if available) from the drop-down list. 

 

• Enter the computer name or IP address of the server computer and click OK. 

• Select a license from the list and click OK. Then close the dialog. 

1.4 Starting the PEAXACT Program 

There are several ways to start the PEAXACT program on a Microsoft Windows platform: 

• Click the Windows start menu and select Programs > PEAXACT 5 > PEAXACT 5. 

• Double-click the PEAXACT 5 icon on the Windows desktop. 
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• Open a command window, cd to the PEAXACT installation folder and type Peaxact at the 
command prompt. 

After starting PEAXACT, a welcome screen opens while the program is loading. 

Note: Starting PEAXACT may need several seconds (up to a minute) for loading the 
MATLAB Runtime. 

If you start PEAXACT without a valid license you will be prompted to activate a license. 
 
If you have problems starting PEAXACT, see the Troubleshooting information. 

Startup Options 

PEAXACT can be started from the command line with additional parameters. Some command 
line options depend on the license. Type PEAXACT –help to see all available options for your 
license. 
 
Parameters in square brackets are optional. Angle brackets represent placeholders which must be 
replaced by specific values. The vertical bar (|) separates alternative arguments. 
 
PEAXACT 

PEAXACT -help | -manual 

PEAXACT [-debug] 

        [-logfile <file>] 

        [-openglfix] 

        [-predict] 

        [-restore | -session <file>] 

        [<file1> [<file2> [...]]] 

-help Displays help for command line usage. 

-manual Opens the user manual. 

-debug Enables verbose log messages. 

-logfile <file> Specifies the log file.  
<file>: The path of a log file. The path must be put in double quotes 
if it contains spaces, e.g.,  
"c:\some folder\peaxact 5.log"  

-openglfix Fixes graphics problems with some video cards. 

-predict Runs a prediction from the command line. Requires a calibrated 
model and sample files to be loaded. The option must be combined 
with options -restore or -session <file> and/or <file*> to load 
models and samples for the analysis. Running predictions from the 
command line has advantages over the graphical user interface. 
Learn more in section Prediction. 
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-restore Reloads the most recently saved session. 

-session <file> Loads a session file. 
<file>: The path of a session file. The path must be put in double 
quotes if it contains spaces, e.g.,  
"c:\some folder\my session.pxs"  

<file*> Loads additional files. These can be model files, sample files, or data 
table files. Multiple file paths must be separated by spaces. A path 
must be put in double quotes if it contains spaces, e.g., "c:\some 
folder\file A.pxm" 
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2 INPUT AND OUTPUT FILES 
This section explains file types used by PEAXACT. 

2.1 Model File 

The central element of PEAXACT is a model which can be saved to and loaded from a file. A 
model file stores one model including all its sub-models and settings. 
 
PEAXACT is backward compatible. It will read model files saved by all previous versions. 

Supported File Formats for Reading 

*.fpm PEAXACT 2.x model file. 

Supported File Formats for Reading and Writing 

*.pxm  PEAXACT model file since version 3. 

2.2 Sample File 

A sample file contains one or more samples, each of which consists of x-data (wavenumbers, 
frequencies …) and y-data (intensities). PEAXACT supports various file formats including some 3D 
formats (files containing multiple samples), and 4D formats (files containing multiple frames of 
multiple samples). 

Sample URI 

PEAXACT uses a uniform resource identifier (URI) to unambiguously identify a specific sample in a 
2D, 3D, or 4D sample file. The URI is composed of the file path followed by the number sign # and 
a sample ID (e.g., c:\data\mixture.txt#3). URIs without number sign and ID refer to all samples in 
the file. For most 2D sample files (single sample) and 3D sample files (multiple samples), the ID 
simply is the sample number within the file (e.g., #3). For 4D sample files (multiple frames), the ID 
is a combination of the frame number followed by the sample number within the frame (e.g., #10-
3). Other format specific IDs are described below. 

Supported File Formats for Reading 

*.0 Bruker OPUS files. The sample ID is the OPUS block name followed 
by the sample number within the block (e.g., #AB-3). 

*.1d Magritek 1D files. 
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*.cdf Agilent netCDF chromatogram files. 

*.csv *.tsv *.dpt *.txt Text files (delimiter separated values). Text files must contain 
tabularly structured data. The first table column is interpreted as 
x-data while following columns are interpreted as y-data. Table 
headers are ignored. The decimal separator should be a point. A 
decimal comma is also acceptable except when the delimiter 
character is a comma. 

*.dx *.jdx *.jcm JCAMP-DX files. 

*.mat Matlab MAT files. Files must contain one numeric matrix variable. 
The variable's name can be arbitrary. The first matrix column is 
interpreted as x-data while following columns are interpreted as 
y-data. 

*.sp Perkin Elmer files. 

*.spa *.spg *.srs Thermo Nicolet OMNIC files. 

*.spc Galactic SPC file. 

*.spe WinView files, WinSPEC files, LightField files. 

*.spv Spekwin32 files. 

*.tdms LabVIEW TDMS files. Files can contain any number of named 
groups, each of which can contain any number of named channels, 
each of which contains data points. Data are recognized when a 
group contains two channels with the same number of data points. 
The first of those channels is interpreted as x-data, the second one as 
y-data. Group names and channel names can be arbitrary. The 
sample ID is the group name (e.g., #Spectrum). 

*.wdf Renishaw WiRE files. 

Supported File Formats for Writing 

*.csv Text files (delimiter separated values). The delimiter for writing text 
files is set by a user preference. 

*.mat Matlab MAT files. 
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2.3 Data Table File 

A PEAXACT data table file is a spreadsheet file in which each row represents a sample and 
columns represent sample URIs and sample features. The concept of data tables is an easy way to 
manage data that belongs together. See also Data Management for further information. 

 

Supported File Formats for Reading and Writing 

*.xls Excel 97-2003-workbook. 

*.xlsx Excel workbook. 

*.csv Text files with tabular data separated by a delimiter character. Note 
that PEAXACT supports the CSV file extension for both sample files 
and data table files. To avoid confusion, it is recommended to use 
Excel files for data tables if possible. 

Table Layout 

PEAXACT can read data table files of the following layouts: 

A) Sample URIs only. The table only consists of a single column which is a list of sample 
URIs. Loading the table loads all referenced sample files. 

B) Sample features only. The table does not contain sample URIs, but only consists of columns 
with numerical or categorical feature values. Such a table cannot be 
loaded directly but must be joined with previously loaded samples. 
See Join Table. 

C) URIs and Features. The table is a combination of A) and B) containing both sample URIs 
and feature values. Loading the table loads all referenced sample 
files and associated features. 

Table Format 

PEAXACT can read data table files if the following formatting rules apply: 
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• Layouts A, C: First table column contains sample URIs (absolute or relative path). 

• Layouts B, C: First table row contains feature names (except for first column). 

• Rows without URI as well as columns without feature name are ignored. 

• Feature names can be anything. When put in curly braces (e.g., {Group}) features are 
treated as categorical, otherwise as numerical. 

• Values of numerical features must be numeric. Values of categorical features can be text 
or numbers, though numbers are treated as text. 

• The following feature names are special and treated differently: 

• Quality: values can be Good or Bad  

• Usage: values can be train, test, or ignore 

• Timestamp: date and/or time as text or serial number 

• Empty cells are interpreted as missing values. 

• In case of duplicate URIs, feature values are merged (values from rows further down take 
precedence over values from rows further up). 

• In case of duplicate feature names, only the first occurrence is considered. 

• For Excel files, only the first worksheet is considered. 

2.4 Session File 

A session file is a snapshot of the PEAXACT workspace. You can save the current session and load 
it later to restore the workspace and continue working where you stopped before. 

Supported File Formats for Reading 

*.mat PEAXACT 2.x Session file. 

Supported File Formats for Reading and Writing 

*.pxs PEAXACT Session file since version 3. 

Auto-Save 

PEAXACT can automatically save session files on shutdown (see preferences). Those files are 
saved in %LocalAppData%\S-PACT\PEAXACT 5\Sessions  

2.5 Session Profile File 

A session profile contains session-related preferences. PEAXACT is shipped with pre-defined 
profiles for typical applications. Profiles can be added, removed, or modified with the Preferences 
Editor, and changes can be saved to or loaded from a profile file. 
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Supported File Formats for Reading and Writing 

*.profile PEAXACT session profile. 

Profile Directory 

When not specified otherwise, profiles are saved to and loaded from the default directory 
%LocalAppData%\S-PACT\PEAXACT 5\Profiles  

2.6 License File 

The license file contains PEAXACT licensing details. On startup, PEAXACT searches the Windows 
registry for a registered license file or displays the License Activation Dialog to load a new license. 

Supported File Formats for Reading 

*.lic PEAXACT License file. 

2.7 Report File 

Report files are used to export graphical or tabular reports. Depending on the report, different file 
formats are available such as text, table, or image files. 

Supported File Formats for Writing 

.pdf Portable Document Format. 

.xls Microsoft Excel 97-2003 Workbook. 

.xlsx Microsoft Excel Workbook. 

.csv Comma separated values. 

.dpt Tab separated values. 

.txt Blank separated values. 

.jpg JPEG image file. 

.png PNG image file. 

.tiff TIFF image file. 

.bmp Bitmap image file. 
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.eps Encapsulated PostScript image file. 

.fig Matlab figure file. 

Default Directory and Filename 

Writing reports typically involves a File Dialog which you can use to browse directories and choose 
a filename. A default filename is suggested according to the heuristic below. Default filenames 
are used automatically when PEAXACT is running in non-interactive mode. 

 

2.8 Log File 

PEAXACT writes messages, warnings, and errors to a log file. The log file path can be changed 
with the command line parameter –logfile. The verbosity of log messages can be increased 
using the command line parameter –debug. 

Default File Path 

%LocalAppData%\S-PACT\PEAXACT 5\Peaxact.log  
 

Default filename is composed of the active model's name (or Untitled if no 
model is active), a suffix which identifies the report (e.g., Prediction), and a 

consecutive number to avoid overwriting existing files. 

The default report directory is specified in the model settings.  
Is the specified directory an absolute path? 

Yes! Default directory is 
taken from model  

settings as is. 

No (relative path)! 
Has the model been saved before? 

Yes! Directory  
is relative to the  

model's path. 

No! Directory is 
%LocalAppData%\S-PACT

\PEAXACT\Reports  
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3 PEAXACT USER INTERFACE 
The PEAXACT graphical user interface consists of multiple interactive windows. Features include: 

• 2D and 3D data visualization 

• Data pretreatments specifically suited for spectroscopic data 

• Interactive data modeling, including Spectral Hard Modeling. 

• Qualitative and quantitative analyses, e.g. 

• Peak Picking 

• Integration 

• Principal Component Analysis (PCA) 

• Cluster Analysis 

• Rank Analysis based on Principal Components 

• Multivariate Curve Resolution (MCR-ALS) 

• Hard Modeling Factor Analysis (HMFA) 

• Peak Fitting / Peak Deconvolution / Indirect Hard Modeling (IHM) 

• Component Fitting 

• Univariate Regression and Prediction 

• Partial Least-Squares (PLS) Regression and Prediction 

• Identification with Lookup Tables 

• Identification with Discriminant Models 

• User-defined Custom Results 

• Customizable reporting 

• Exporting to several output formats 
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3.1 Main Window 

When you start the PEAXACT program it displays the main window. The main window contains 
controls for managing, modifying, and displaying models and samples. 

 
PEAXACT main window with models and samples 

1) Menu bar 
2) Toolbar 
3) Status bar 
4) Model Tree Panel 
5) Samples Panel 
6) Properties Panel 
7) Plot Panel 

The main window is structured into four panels. Drag the gray bar between two panels to resize 
them or hide/re-show panels by clicking the arrows on the resize bar. 
  

1 

2 

4 

5 

6 

7 

3 
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3.1.1 Menu bar 

Use the menu bar to access actions by category. 

File Model File Management, Preferences, Sessions 

Data Data Management, Data Inspector 

Edit Model  Modeling Tools 

Analysis Analysis & Reporting 

Help Documentation, Support, Licensing, Web Resources… 

3.1.2 Toolbar 

Use the toolbar to quickly access frequently used actions. 

   New Model, Open Model, Save Model 

  Load Samples, Load Data Tables 

 Data Inspector 

        Add Integration Model Peak 
Add & Auto-fit Hard Model Peaks 
Import Hard Model Components 
Adjust Hard Model Peaks 
Adjust Hard Model Components 
New Calibration Model 
New Classification Model 
Add Custom Result 

  Linear Component Fit preview  
Component Fit preview according to Hard Model settings 

       Data Filter Tool, Data Cursor Tool, Pan Tool, Zoom In Tool, Zoom 
Out Tool, Full Zoom, Full Y-zoom 

 Preferences Editor 

 User Manual 
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3.1.3 Status bar 

Use the status bar to obtain status information. 

 

1) Busy Indicator: Indicates whether PEAXACT is currently busy and cannot respond to 
mouse-clicks or pressed keys. 

2) Current Profile: Displays the currently active session profile. Left-click to open the 
Preferences Editor. 

3) Status Message: Displays the status of the last action carried out. Left-click to open the 
message window, where all recent status messages are displayed. 

3.1.4 Model Tree Panel 

The Model Tree Panel displays opened model files, each represented by a tree structure. Use the 
tree to access certain model elements. 

 

-- Empty item. Select this if no model should be active. 

2 3 1 
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 Model Name Each top-level tree item represents a model file. The displayed 
model name corresponds to the file name, marked with an asterisk 
(*) if the model has unsaved changes. 

 Pretreatment Pretreatment Model: the sub-model with options for the 
manipulation of the sample signal. Pretreatments are applied prior 
to all other operations. 

 Name Data Filter: a named x-region of the sample signal to be used for 
further operations (after pretreatments), mainly for PLS calibration. 

 Integration Integration Model: the sub-model for the calculation of component 
areas from the sample signal by numerical integration. 

 Name Integration Model Component: a named container for Integration 
Model Peaks, representing a chemical component. The component 
area is the sum of its peak areas. 

 Peak N Integration Model Peak: defines x-limits and a baseline for the 
numerical integration of the sample signal. 

 Hard Model [Sample] Hard Model: the sub-model for the calculation of component 
weights from the sample signal by fitting peak curves. The name of 
the sample to which the model was last fitted is displayed in 
brackets. 

 Baseline Hard Model Baseline: a linear or quadratic curve which is fitted to the 
sample signal along with Hard Model Components. 

 Name Hard Model Component: a named container for Hard Model Peaks, 
representing a chemical component. The component weight is a 
scaling factor for its peaks. 

 Peak N Hard Model Peak: defines the position and shape parameters of a 
peak curve to be fitted to the sample signal. 

 Calibration [Method] Calibration Model: the sub-model for the quantitative conversion of 
the sample signal to numerical features by means of univariate or 
multivariate regression. The calibration method is displayed in 
brackets. 

 Name Calibration Model Component: a named component trained with 
reference samples to predict feature values from unknown samples. 

 Classification [Method] Classification Model: the sub-model for the qualitative conversion of 
the sample signal to a categorical feature. The classification method 
is displayed in brackets. 
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 Name Classification Model Component: a named component trained with 
reference samples to identify feature classes from unknown 
samples. 

 Custom Results Custom Results: the sub-model for user-defined results. 

 Name Numerical Result: a named custom result returning a number. 

 Name Categorical Result: a named custom result returning text. 

Selecting and Activating Models 

Use the mouse, e.g., to select an element from the tree. This activates the model to which the 
element belongs. Note that only one model can be active at a time. Many operations of PEAXACT 
implicitly operate on the active model. 
 
Selecting model elements affects other parts of the main window: 

• Display of the element's parameters (see Properties Panel) 

• Display and/or highlighting of the element's plot (see Plot Panel) 

• Enabling of element-specific actions in the Menu bar and Toolbar 

Sometimes it is favorable to not have any model active. Select the empty item (--) for this 
purpose. 

3.1.5 Samples Panel 

The Samples Panel shows a list of loaded samples. Use the panel to access certain samples. 

 

-- Empty item. Select this if no sample should be active. 
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Sample Name Each item represents a sample. The sample name is composed of the 
sample filename and ID (see Sample File). Additional information, if 
any, may be added to the name: 
 

The name is crossed out if the feature Quality is set to Bad. 
 

test or ignore indicate the value of feature Usage. The default value 
train is not shown. 
 
t indicates that a Timestamp is available. 
 

#feat. indicates the number of other available features. 
 

[C] indicates that a Component Fit exists. 

Selecting and Activating Samples 

Use the mouse, e.g., to select one or more samples from the list. Press CTRL+A to select all 
samples. The last selected sample becomes the active sample, noticeable by its name being 
displayed in bold letters. Many operations of PEAXACT – including all analyses – are applied to 
the selected samples; some operations implicitly operate on the active sample. 
 
When activating a sample whose URI points to a missing file you are prompted to Update Missing 
Files. 
 
Activating a sample affects other parts of the main window: 

• Display of the sample's spectrum (see Plot Panel) 

• Enabling of specific actions in the Menu bar and Toolbar 

Sometimes it is favorable to not have any sample active. Select the empty item (--) for this 
purpose. 

3.1.6 Properties Panel 

The Properties Panel displays either Model Properties or Sample Properties. Switch between the 
two by clicking on the respective heading. 

Model Properties 

Use the Model Properties Panel to get and set properties of the model currently active in the 
Model Tree Panel. Visible properties depend on the selected model element. Some properties are 
read-only, others are editable. 
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Sample Properties 

Use the Sample Properties Panel to get and set properties of the sample currently active in the 
Samples Panel. Properties are grouped into categories. Categories File and XY-Data are read-
only, category Features is editable. 

 

3.1.7 Plot Panel 

The Plot Panel contains a graphical display of the items selected in the Model Tree Panel and in 
the Samples Panel. Use the mouse, e.g., to interact with the plots to select and edit model 
elements. 
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Available Graphs 

 Sample Spectrum 
Graph of the active sample’s spectrum (black line). If a model is 
active in the Model Tree Panel, the sample is modified according to 
the active model's Pretreatment Model. The sample plot cannot be 
modified interactively. (Hint: Use the Data Inspector to plot multiple 
samples) 

 Pretreatment Model – Excluded Ranges 
Graph of excluded ranges (transparent gray patches) of the active 
model's Pretreatment Model. Excluded ranges can be modified with 
the mouse (see preferences). 
 
 

 Pretreatment Model – Rubber Band Baseline Nodes 
Graph of rubber band baseline nodes (black circles at y = 0) of the 
active model’s Pretreatment Model. Baseline nodes can be modified 
with the mouse. 
 
 

 Pretreatment Model – Reference Peak for Normalization 
Graph of the reference peak for normalization of the active model’s 
Pretreatment Model. The reference peak can be modified with the 
mouse. 
 
 

 Data Filter 
Graph of the currently selected Data Filter of the active model’s 
Pretreatment Model. The Data Filter can be modified with the 
mouse. 
 
 
 

 Integration Model 
Graph of peaks of the active model's Integration Model (colored 
areas). Integration Model Peaks can be modified with the mouse. 
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 Hard Model and Residuals 
Graph of baseline (dashed blue line), components (solid blue lines), 
and peaks (cyan lines) of the active model's Hard Model (red line). 
Baseline and peak plots can be modified with the mouse (when not 
in component fit preview mode). 
 
If a sample is active in the Samples Panel, the sample spectrum is 
plotted too, and the differences (residuals) between Hard Model (red 
line) and sample (black line) are shown in a second graph. 
 

Interactive Modeling 

Most model-related graphs can be modified interactively with the mouse. Available actions differ 
from graph to graph but typically include: 

• left-clicking a graph to select the corresponding element in the Model Tree Panel 

• dragging a graph while the left mouse-button is pressed to change the graph’s position or 
shape 

• right-clicking a graph to open the corresponding context-menu 

• hitting the DEL-key to delete the selected element from the model 

• hitting the F2 key to rename the selected model element 

Detailed descriptions can be found in section Modeling. 

3.2 Working in Sessions 

A PEAXACT session contains models and samples, and represents an isolated environment where 
analyses execute. By default, PEAXACT starts with an empty session where you can create 
models and load samples. You can also create new sessions, save the current session to a session 
file or load a saved session file to continue working where you left before. Each session has 
associated settings (see Session Profile) that can be adjusted to the kind of data you want to work 
with, e.g., Raman spectra or NMR spectra. 

3.2.1 New Session 

Menu bar: File > New Session > (Profile) 

When starting a new session, you must pick a session profile to work with. Starting a new session 
clears the current workspace and resets the main window to its initial state: all windows except 
the main window are closed, all model files are closed, and all sample files are unloaded. 
 
You will be asked to save the current session first. 
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3.2.2 Open Session 

Menu bar: File > Open Session > Load Session File… 
Menu bar: File > Open Session > … 

You can choose between loading a session from file (by using the File Dialog) and reloading a 
recently opened session. 
 
When opening a session file, the current session is closed, and the workspace of the opened 
session is restored. 

Drag and Drop 

A fast way to open a session file is by using drag & drop. Drag a single session file from the 
Windows Explorer (e.g.) and drop it into the Model Tree Panel or the Samples Panel. Note: if you 
drag & drop multiple files, PEAXACT ignores any session files among them and tries to open 
model files or sample files instead. 

Command Line Alternatives 

peaxact -session <file>  
peaxact -restore  

When starting PEAXACT from the command line, you can pass additional parameters to either 
open a certain session file or to restore the most recently saved session. 

What is Restored from Session Files? 

• Models are restored exactly to the state when the session was saved (see below). 

• Samples are restored exactly to the state when the session was saved, including 
filenames. When you move or rename these files on your hard disk, filenames stored in the 
session still point to the old location and need to be updated after the session is restored 
(see below). 

• Component Fits 

• Selected and active elements of the Model Tree Panel and Samples Panel are restored. 
Therefore, the Properties Panel and Plot Panel also are restored to their previous state. 

• Session settings 

Caution with Models Restored from Sessions! 

A model restored from a session file must be treated with care, especially if 

• multiple sessions exist containing the model at different building stages 

• the model was modified and saved to file after the session was saved 



3 - PEAXACT USER INTERFACE 28 

S o l u t i o n s  f o r  P r o c e s s  A n a l y t i c s  &  C o n t r o l  T e c h n o l o g y  

In these cases, it is possible to restore a model from a session file which in the meantime has been 
replaced by a newer version. You can choose whether to reload the newer model or continue 
working with the one contained in the session file. 

 

Update Missing Sample Files 

Samples stored in a session file contain references (URIs) to files from the moment the session 
was saved. When you move or rename these files on your hard disk, filenames stored in the 
session still point to the old locations. After reloading a session, you may have to update these file 
references. PEAXACT informs you to update missing files when it tries to load data from a missing 
file. 

3.2.3 Save Session 

Menu bar: File > Save Session As… 

Use the File Dialog to browse directories and select a filename for the session to be saved. 
 
When saving a session file, the current workspace is written to the hard disk. 

Auto-Saving 

The current session can be saved automatically to a special directory on PEAXACT shutdown (see 
preferences). 

What is Stored in Session Files? 

• Models. Note that unsaved model changes are not saved to model files. Therefore, these 
models will still be marked unsaved when the session is re-opened later. 

• Samples 

• Component Fits 

• Selected and active elements of the Model Tree Panel and Samples Panel 

• Session settings 
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3.3 Model Management 
3.3.1 About Models 

What are Models? 

A model is a set of parameters used by PEAXACT algorithms to solve analysis tasks, e.g., 
predicting concentrations from measured spectra. Models are structured into sub-models for 
specific sub-tasks: 

• Pretreatment Model: parameters for data manipulation. 

• Integration Model: parameters for peak integration. 

• Hard Model: parameters for peak fitting and component fitting. 

• Calibration Model: parameters for quantitative analyses. 

• Classification Model: parameters for qualitative analyses. 

• Custom Model: user-defined expressions to calculate custom results. 

Modeling and Analysis 

The lifetime of a model passes at least two stages: 

• First, an analysis method must be chosen, and appropriate model parameters must be set. 
This process is called modeling. The amount of information that must be provided during 
modeling depends on the analysis method. For instance, calibration methods require a 
Calibration Model; hard modeling methods require a Hard Model. 

• After the model has been created, it can be utilized for analyses. 

Getting Access to Model Parameters 

The Model Tree Panel is a graphical control designed for browsing the model's structure. It quickly 
gives an overview of all the sub-models and their content. The model tree can be used to select 
any element of the model and then get displayed additional information about that element in 
the Properties Panel. 
 
For most model elements, the Properties Panel gives access to model parameters and their 

values. When clicking the model item  in the Model Tree, the Properties Panel displays a 
summary of the most important parameters in a tabular report. 

Model File 

The model file is a physical file on the hard disk which is written by PEAXACT and stores all model 
parameters. 

Exporting Reports 

Menu bar: File > Export > … 
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Model reports are tabular or graphical representations of model parameters. Model reports can 
be re-created at any time because the necessary information is persistently stored within the 
model file. PEAXACT can export reports to different output formats such as XLS or PDF. 
 
The following model reports are available: 

Model Summary A tabular summary of model parameters. This report is also 
displayed in the Properties Panel after selecting the top-level model 
item in the Model Tree Panel.  

Model Details A full tabular report of all model parameters for documentation 
purposes. 

Hard Model XY Data A table containing y-values of the Hard Model calculated at x-values 
of the active sample. The data can be used to reproduce plots of the 
Hard Model like those in the Plot Panel. 

Calibration Data Table A PEAXACT data table containing sample URIs and feature values 
used to create the Calibration Model. 

Classification Data Table A PEAXACT data table containing sample URIs and feature values 
used to create the Classification Model. 

Plot This report exports the current content of the Plot Panel to an image 
file. 

3.3.2 New Model 

Toolbar:  
Menu bar: File > New Model 
Hot key: CTRL + N 
Context menu: Model Tree Panel > New Model 

Adds a new model to the Model Tree Panel. 

Model Name 

The new model's name is "Untitled" by default. If an opened model already has this name, a 
consecutive number is added. 
 
A model is always named after its filename. To rename a model in PEAXACT, save it under a new 
filename. To rename a model outside PEAXACT, simply rename the file. Caution: Do not change 
the file extension! 
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Initial Settings 

Each time a new model is created, initial settings are copied from the then-active session profile. 
You can later modify model settings of each model individually in the Model Properties Panel. 

3.3.3 Open Model 

Toolbar:  
Menu bar:  File > Open Model… 
Hot key:  CTRL + O 
Context menu:  Model Tree Panel > Open Model… 
Drag & drop: from Explorer to Model Tree Panel 

Opens a previously saved model file. A File Dialog can be used to browse directories and select 
one or more model files to be opened. Choose a file filter from the drop-down list to localize 
certain model files. Opened models are added to the Model Tree Panel. 

Drag and Drop 

A fast way to open model files is by using drag & drop. Drag any files from the Windows Explorer 
(e.g.) and drop them into the Model Tree Panel. Hint: If your directory contains many different 
files, you can simply select all files and drop them to the Model Tree Panel. PEAXACT 
automatically filters out model files. You may also drag & drop directories to load all model files 
from the directory. 
 
If any model is active while dropping files to the Model Tree Panel, you will be asked whether to 
open these files or to import components into the active model. 

 

Reload Open Model 

If you open a model file that is already opened, you will be asked whether to reload the model or 
discard all unsaved changes (if any). 

3.3.4 Close Model 

Menu bar:  File > Close Model 
Hot key: CTRL + W 
Context menu: Model Tree > Model Item > Close 
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Closes the active model file. The model is removed from the Model Tree Panel and the next 
available model becomes active. 

Unsaved Changes 

If the active model contains unsaved changes, you will be asked to save the model first. 
Otherwise, the model file is closed directly. 

3.3.5 Close All 

Menu bar:  File > Close All 

Closes all model files. This is a fast way to clear the Model Tree Panel. If any model has unsaved 
changes, you will be asked whether to save them or discard changes. 

Closing Models on Shutdown 

All models will be closed when closing the PEAXACT main window. Respectively, you get the 
chance to save unsaved changes. 

3.3.6 Save Model 

Toolbar:  
Menu bar: File > Save Model 
Hot key: CTRL + S 
Context menu: Model Tree > Model Item > Save 

Saves the active model to its file. If the model has never been saved before PEAXACT falls back to 
Save As. 

3.3.7 Save Model As 

Menu bar: File > Save Model As… 
Context menu: Model Tree > Model Item > Save As… 

Saves the active model to a new file. A File Dialog can be used to browse directories and select or 
enter a filename for the model to be saved. 

Overwriting Existing Files 

As a precaution, you cannot save a model to a file of another model that is currently opened in 
PEAXACT. You must close the other model before overwriting its file. 
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3.3.8 Duplicate Model 

Menu bar: File > Duplicate Model 
Context menu: Model Tree > Model Item > Duplicate 

Creates an exact copy of the active model. The new model is added to the Model Tree Panel. The 
duplicate gets the name of the source model plus a consecutive number. 

Using Duplicates 

Using duplicates is useful if you already have a populated model and want to compare the effects 
of different model settings without changing the original model. 

3.4 Data Management 
3.4.1 About Samples 

What are Samples? 

In PEAXACT, the term Sample refers to the digital representation of a physical sample. Each 
digital sample at least consists of a spectrum (the sample’s xy-data) and may have other features 
associated with it. 

The Sample URI 

Samples are stored in sample files. PEAXACT works with references to sample files, so called 
uniform resource identifiers (URI). The reference is composed of a filename and – because the file 
may contain more than one sample – a sample ID. Each URI unambiguously identifies a specific 
sample. Learn more about URIs in section Sample File. 
 
Example URI: 
C:\Program Files\S-PACT\PEAXACT 5\Data\NIR - Gasoline\References\ NIR.mat#15  

Sample Name 

The sample name is a shortened URI, namely the sample file name and the sample ID. Sample 
names are often used in PEAXACT, e.g., in report dialogs, in result files, or as display names in the 
Samples Panel. 
 
Example Name: 
NIR.mat#15  

Features 

The term sample feature refers to any kind of information that is associated with a sample. Each 
feature has a name and a numerical or categorical (text) value. Respectively, features are called 
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either numerical features or categorical features. PEAXACT uses the feature name to distinguish 
between numerical and categorical features. There are also some reserved names for special 
features. The following table describes all types of features: 

Numerical A feature is considered numerical if its name is neither put in curly 
braces nor is a special name (see below). Example names for 
numerical features: Cyclohexane [mol%], Pressure [bar], 
Temperature [°C], Octance Number, Salinity. 
Although not required, it is recommended to include the unit of 
measurement in the name. The value of numerical features must be 
numbers. 

Categorical A feature is considered categorical if its name is put in curly braces. 
Example names for categorical features: {Replication Group}, 
{Batch}, {Temperature Level}, {Operator Name}, {Instrument ID}. 
The value of categorical features must be text or numbers, though 
numbers are treated as text.  

Quality A special feature name to label the quality of a sample. You can 
choose from a predefined set of values: 
Good: The sample is considered for all modeling operations and 
analyses. This is the default value. 
Bad: The sample is excluded from all modeling operations and all 
analyses. Assign this value, e.g., if the sample spectrum is an outlier 
or too noisy. 

Usage A special feature name to specify the usage of a sample for 
calibration or classification. You can choose from a predefined set of 
values: 
Train: The sample is used for training of the calibration/classification 
model. This is the default value. 
Test: The sample is used for validation. 
Ignore: The sample is not used for neither training not testing. 

Timestamp A special feature name to specify the acquisition date and/or time of 
the sample spectrum. The value must be either a date in the format 
YYYY-MM-DD, a time in the format hh:mm:ss, or a combination of both 
YYYY-MM-DD hh:mm:ss. 

Sample features are used for many purposes: 

• coloring and arranging 2D and 3D plots in the Data Inspector 

• sorting samples in the Samples Panel 

• plotting results against feature values (e.g., in analysis reports) 

• effecting whether samples are used at all for modeling and analyses (see Quality) 

• effecting how samples are used in calibration/classification (see Usage) 

• providing reference values for calibration/classification and validation 
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• joining features from a loaded table with existing samples by means of a matching key 
feature 

Sample File and Data Table File 

Both, sample files and data table files are physical files on the hard disk. Sample files contain 
xy-data of one or multiple samples and are typically generated by measurement software. Data 
table files contain references to sample files plus optional sample features and are typically 
created by the user, either with PEAXACT or with Excel. 

Getting Access to Samples 

The Samples Panel can be used to select a sample and then get displayed additional information 
about it in the Properties Panel. 

3.4.2 Load Sample Files 

Toolbar:  
Menu bar: Data > Load Samples… 
Hot key: CTRL + L 
Context menu: Samples Panel > Load Samples… 
Context menu: Model Tree > Hard Model Item > Load Underlying Sample 
Drag & drop: from Explorer to Samples Panel 

Loads sample spectrum files. A File Dialog can be used to browse directories and select one or 
more sample files to be loaded. Choose a file filter from the drop-down list to localize certain 
sample files. 
 
PEAXACT loads all samples it finds in a sample file. URIs are created automatically from the 
filename and IDs of the samples within the file. See also Sample Files for further information 
about URIs. 
 
A loaded sample gets added to the Samples Panel if 

• it is new, i.e., none of the already loaded samples has the same URI 

• in case of OPUS-files, the block name matches the block name filter (see preferences) 

Drag and Drop 

A fast way to load sample files is by using drag & drop. Drag files from the Windows Explorer 
(e.g.) and drop them into the Samples Panel. Hint: If your directory contains many different files, 
you can simply select all files and drop them to the Samples Panel. PEAXACT automatically filters 
out sample files. You may also drag & drop directories to load all sample files and data table files 
from the directory. 
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3.4.3 Load Data Tables 

Toolbar:  
Menu bar: Data > Load Table… 
Hot key: CTRL + T 
Drag & drop: from Explorer to Samples Panel 

Loads data table files. A File Dialog can be used to browse directories and select data table files to 
be loaded. 
 
PEAXACT loads all samples it finds in a data table file. URIs are taken as is from the first table 
column, feature values are taken from other table columns. 
 
A loaded sample gets added to the Samples Panel if it is new, i.e., none of the already loaded 
samples has the same URI. Otherwise, features of the loaded sample get merged with the 
existing sample. 

Drag and Drop 

A fast way to load data tables is by using drag & drop. Drag files from the Windows Explorer (e.g.) 
and drop them into the Samples Panel. You may also drag & drop directories to load all sample 
files and data table files from the directory. 

3.4.4 Unload Selected Samples 

Menu bar: Data > Unload Selected Samples 
Hot key: CTRL + U 
Context menu: Samples Panel > Unload Selection 

Unloads selected samples and removes them from the Samples Panel. If the currently active 
sample gets removed the next available sample becomes active. Component Fits to removed 
samples are removed along with them. 

3.4.5 Unload All 

Menu bar: Data > Unload All 

Unloads all samples at once. This is a fast way to clear the Samples Panel. All Component Fits are 
removed as well. 
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3.4.6 Save Data Table 

Menu bar: Data > Save Data Table… 

Menu bar: Data > Data Inspector… > Data Table Editor >  
Context menu: Samples Panel > Save as Data Table… 

Exports selected samples to a data table file. A File Dialog can be used to browse directories and 
select or enter a filename. 

3.4.7 Update Missing Files 

Menu bar: Data > Update Missing Files 
Samples Panel: Activate a sample whose file is missing 

Checks all samples for invalid URIs. If any are found, a dialog is shown which can be used to either 
relocate these files or unload affected samples. 

 

URIs become invalid if sample files get moved or renamed on the hard disk while being loaded in 
PEAXACT, or if a session file gets opened which contains samples that have been moved or 
renamed since the session was saved. 

Relocate 

Relocating comprises two steps: 

• Relocating the next missing file, i.e., select a new target directory and target filename 
using the File Dialog. 

• If possible, automatically relocating more missing files with matching names from the 
source directory to the selected target directory. 
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Note: Relocating sample files is fast and easy if files were only moved from one 
directory to another directory. Try to avoid moving sample files from one directory to 
many different directories. Also avoid renaming sample files. 

Both steps execute until either all missing files are relocated or the user cancels. 

Unload 

Unloading removes all samples which are pointing to missing files. 

3.4.8 Edit Samples 

Editing samples refers to adding, removing, and modifying sample features. It is not possible to 
edit the sample spectrum (use models instead), or the sample file path (update missing files 
instead). 

Edit Samples with PEAXACT 

PEAXACT comes with its own integrated Data Table Editor which is part of the Data Inspector. 

Menu bar: Data > Data Inspector… > Data Table Editor 
Menu bar: Analysis > Data Inspector… > Data Table Editor 
Context Menu: Samples Panel > Data Inspector > Data Table Editor 

In addition, the context menu of the Samples Panel offers shortcuts to changing the Quality and 
Usage features, and to fully removing all features. These actions are applied to selected samples. 

Context Menu: Samples Panel > Set Quality > … 
Context Menu: Samples Panel > Set Usage > … 
Context Menu: Samples Panel > Remove Features 

Edit Samples with Microsoft Excel 

Microsoft Excel can be used as an external editor for samples. You can use Excel to create and edit 
data table files and then load these data tables in PEAXACT. Because Excel is a powerful 
spreadsheet editor this is a convenient way to edit samples. However, keep in mind that you must 
load the data table file in PEAXACT to import changes made externally. 
 
Consider the data table formatting rules when changing the table. Beside these rules you are free 
to use all Excel functionalities like formulas, diagrams, filters, conditional formatting, and so on. 

Common practice 

A typical procedure for editing samples involves creating an initial data table file with PEAXACT 
and then editing the file with Excel: 

• Load sample files in PEAXACT 
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• Select samples in the Samples Panel and choose Data > Save Data Table from the menu. 
This creates a data table file that contains sample URIs only. 

• Use Excel to edit the data table file (e.g., add concentrations) 

• Load the final data table file in PEAXACT to import features to existing samples. 

3.4.9 Sort Samples 

Context Menu: Samples Panel > Sort Selection by 

Sorts and reorders selected samples in the Samples Panel. Samples can be sorted by name or any 
available sample feature. 

Sort order 

Unsorted samples get sorted in ascending order (a to z, 0 to 9) when sorted once, and in 
descending order when sorted a second time. The sort order has no effect on any analysis results 
but sometimes on how the results are displayed. 

3.4.10 Create Mean Sample 

Menu bar: Data > Create Mean Sample… 

Creates and saves a mean sample from selected samples in the Samples Panel. At least 2 samples 
must be selected. The mean sample is created by averaging spectra and by copying feature values 
which are the same for all selected samples. 

 

Modify If a model is active, its Pretreatment Model can be applied to all 
selected samples before the mean spectrum is calculated. Tick Apply 
data pretreatments to use this option. 
 
Note: Do not enable this option if you later intend to analyze the 
new sample by a model because this could produce unexpected 
results (double pretreatments). 
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Group by The optional grouping feature for group-wise creation of mean 
samples.  
 
Without grouping a single mean sample is created from all samples.  
 
If you choose a grouping feature, a separate mean sample is created 
for each group (group = samples having the same feature value). 
Samples with missing feature value are ignored. For example, you 
can use grouping to create a single mean sample for each group of 
repeated measurements. 

Save as The filename for saving the mean sample spectrum. 
 
If grouping is enabled, a separate file is saved for each group. The 
chosen filename automatically gets extended by the group name. 

Click OK to create mean samples, save them to files, and add them to the Samples Panel. 

3.4.11 Create Representative Sample 

Menu bar: Data > Create Representative Sample… 

Creates a representative sample from selected samples in the Samples Panel. At least 2 samples 
must be selected. A representative sample is like a mean sample, but it is created from samples 
having the most different spectra among the selected samples. The representative sample 
spectrum typically will contain all peaks of all samples in a very pronounced manner. This makes it 
a suitable sample for creating a representative Hard Model for HMFA. 

 

Modify If a model is active, its Pretreatment Model can be applied to all 
selected samples before the mean spectrum is calculated. Tick Apply 
data pretreatments to use this option. 
 
Note: Do not enable this option if you later intend to analyze the 
new sample by a model because this could produce unexpected 
results (double pretreatments). 
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Considered Samples The number of samples to consider for creating the representative 
sample. The algorithm will automatically pick the samples with most 
different spectra. 
The number should correspond to the number of chemical 
compounds in your measurements.  

Save as The filename for saving the representative spectrum. 

Click OK to create the representative sample, save it to a file, and add it to the Samples Panel. 

3.5 Reporting of Results 

PEAXACT uses Report Windows to visualize results in graphical and tabular reports. All Report 
Windows have a similar layout and common functionalities which are explained in this section. 
Variations from the typical layout and custom functionalities are explained in separate sections 
dedicated to the individual Report Windows. 

 
Typical Layout of Report Windows 

Toolbar 

  Export report as shown in the Report Panel to a file. Available file 
formats depend on the type of report, but in general, graphical 
reports can be exported to image files while tabular reports can be 
exported to text or spreadsheet files. 
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  Copy report to clipboard. Graphical reports are copied as rendered 
images or vector images (see preferences) while tabular reports are 
copied as text. 

  Open the Print Preview Dialog. 

 Data Filter Tool: enable to interactively edit Data Filters using the 
mouse. 

 Data Cursor Tool: enable to read data directly from a graph by 
interactively placing Data Tips in a plot. 

 Profile Cursor Tool (2D plots only): enable to display y-values of 
overlapping plots at a clicked x-position. 

 Pan Tool (2D plots only): enable to interactively move the visible plot 
area with the mouse. 

 Rotate Tool (3D plots only): enable to interactively rotate the 
orientation of a graph with the mouse. 

  Zoom Tools (2D plots only): enable to interactively zoom in or out on 
a graph with the mouse. 

  Full Zoom, Full Y-zoom 

 Open Preferences Editor 

 Show/Hide color bar 

Note: The exact set of available toolbar icons depends on the specific Report Window. 
However, same icons have the same meaning each time. 

Report Selection & Customization 

The report to be displayed in the Report Panel can be chosen from a drop-down list located at the 
top-right of the Report Window. Each individual Report Window has a very specific list of 
available reports. 
 
Most reports can be customized in various ways using some controls located at the right of the 
window. 

Changing Report Appearance 
The appearance of reports (e.g., font size, visible elements of graphs) is controlled by several 
adjustable preferences. You can reach the Preferences Editor from the toolbar. 

Editing Titles and Labels 
All titles and labels of graphical reports can be edited when clicking on them. 
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Note that your text is processed by a TeX interpreter, i.e., you can use ^ for superscripts, _ for 
subscripts, {} for grouping. Also, you can use special commands for Greek letters (\alpha, \beta, 
\gamma, \Gamma, …). When finished editing, press the Escape key, or click anywhere outside the 
text field. 

Note: User edited titles and labels are replaced by default text each time the selected 
report changes. Therefore, it is recommended to customize titles and labels as a final 
step before exporting the report to a file. 

Positioning of Legends 
Legends in graphical reports are positioned automatically to least interfere with the plots. 
However, you can reposition legends interactively by dragging them to the desired location. 

 

Print Preview Dialog 

The Print Preview is a dialog box showing the graphical report as it will print. A scaled version of 
the report displays in the right-hand pane of the window. 
 
Use the Print Preview dialog box, shown below, to control the layout and appearance of graphical 
reports before sending them to a printer or print file. 
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3.6 Data Inspector 

Menu bar: Data > Data Inspector… 
Menu bar: Analysis > Data Inspector… 
Context Menu: Samples Panel > Data Inspector 

The Data Inspector is a window designed for editing and visualizing samples. For this purpose, the 
Data Inspector consists of two parts: 

• Data Table Editor for editing sample features 

• Data Plotter for visualizing sample spectra and features in various 2D and 3D plots. 

The Data Inspector does not require a model; it operates on samples alone. You typically use the 
Data Inspector to visually inspect sample spectra and manage features before you start with 
modeling. 
 
To learn more about samples, see About Samples. 

Opening the Data Inspector 

When you open the Data Inspector, selected samples are imported from the Samples Panel into 
the Data Inspector. To import a separate set of samples, simply change the selection in the 
Samples Panel and open the Data Inspector again. 

Caution: Re-opening the Data Inspector refreshes its content. Unsaved changes made 
in the Data Table Editor will get lost. 
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Closing the Data Inspector 

When you close the Data Inspector while the Data Table Editor has unsaved changes, you will be 
asked whether to apply changes. Doing so exports features back to the Samples Panel. 

3.6.2 Data Table Editor 

The Data Table Editor can be used to add, remove, and modify sample features. Each feature is 
represented by a table column. The first two columns are read-only; they contain the sample's 
directory and file name. 

 
Data Inspector – Data Table Editor 

1) Toolbar; see Report Window 
2) Data Table Editor and Data Plotter tabs 
3) Table with columns: 

• Directory: path of sample file (read-only) 

• Sample: sample name (read-only), printed in red if file is missing 

• any number of feature columns (editable) 

4) Actions applicable to selected rows 
5) Actions applicable to feature columns: add, remove, hide, show, rename 
6) Apply button: accept table changes and update samples in the main window 
7) Close button: close the Data Inspector window 

1 

2 
4 

5 

3 

7 6 
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Sort Rows 
Rows can be sorted by clicking on a column header. Clicking multiple times toggles the sort order. 
Pressing the CTRL-key while clicking multiple column headers enables multi-level sorting. 

Filter Rows 
Rows can be filtered using the filter editor below the column header. Only rows matching the 
filter will be displayed. Choose a value from the drop-down list or enter the desired value into the 
text field. Filter expressions may contain wildcard characters to match any character, e.g., 3.1415* 

* matches zero or more arbitrary characters. 

+ matches one or more arbitrary characters. 

? matches exactly one arbitrary character. 

Filter expressions may also be logical expressions, e.g., > 0 or <>ignore. 

> greater than filter 

>= greater or equal filter 

< less than filter 

<= less or equal filter 

= equal filter (exact match) 

<> not equal filter 

Re-arrange Columns 
Table columns can be re-arranged by dragging a column header and moving the column to the 
desired position.  

Resize Columns 
The width of a table column can be changed by dragging its border to the desired position. You 
can also auto-adjust the column width by double clicking the border. 

Export Options 

Use the Export Tools   from the toolbar to export the table to a Data Table File or to the 
Windows clipboard, respectively. Columns Directory and Sample are combined and exported as a 
single column representing sample URIs. When exporting to a file, URIs pointing to subdirectories 
of the table file path are converted to relative paths. For more information about sample URIs see 
Sample Management. 

Join Table 

Use the Join Tool  from the toolbar to open the Join Table Dialog and join features of a second 
table with samples of the current table. The second table may or may not contain sample URIs 
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(see Data Table File for possible table file layouts). Features of the second table are merged with 
the current table either by matching URI, or row-by-row, or by a common feature. 

 

Load… Click to load a second table (joining table) which should be merged 
with the current table.  
 
Note: Joining tables will not add new rows (new samples) from the 
joining table to the current table. Only columns (features) will be 
merged. Use the PEAXACT main window if you want to load 
additional samples. 

Features The list displays all features available in the joining table. Select 
which features you want to merge with the current table. 

Select All / Unselect Click to select / unselect all features. 

Merge Options 

Key The key property to be used for matching rows of the joining table 
with rows of the current table. The key must be a property which 
both tables have in common. The following options are available: 
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 Sample URI. Rows of the joining table are merged with rows of the 
current table for rows with identical URIs. Each row of the joining 
table is merged with zero or one row of the current table. 

 Row Index. Rows of the joining table are merged with the current 
table row-by-row. If the joining table has more rows than the current 
table, additional rows are ignored. 

 Common feature. Rows of the joining table are merged with rows of 
the current table according to the value of a common feature. You 
may specify additional match conditions, e.g., whether the key value 
must match exactly or may be within a tolerance. 

Match The option for how key values are matched. The following options 
are available: 

 exact. Each row of the joining table is merged with all rows of the 
current table where the key matches exactly. 

 closest. Each row of the joining table is merged with the one row of 
the current table where the key is the closest match within the 
specified Tolerance (see below). 

 closest below. Each row of the joining table is merged with the one 
row of the current table where the key value of the joining table is 
closest below the key value of the current table. 

 closest above. Each row of the joining table is merged with the one 
row of the current table where the key value of the joining table is 
closest above the key value of the current table. 

 all within tolerance. Each row of the joining table is merged with 
all rows of the current table where the key value is within the 
specified Tolerance (see below). 

 case-insensitive. Each row of the joining table is merged with all 
rows of the current table where the key matches exactly except for 
the case. Available only for categorical keys. 

Tolerance The tolerance for the matching of numerical key values. The 
tolerance value can be Inf (= infinite) which effectively deactivates 
the tolerance so that there will always be at least one match. For a 
non-Inf tolerance it may also happen that no key matches. 

Tolerance Unit The unit of the tolerance value. Available only when Key = 
Timestamp. 
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Columns with identical names 
Specifies how a column of the joining table (B) should be treated if 
the current table (A) has a column with same name. The following 
options are available: 

 keep A only. The column of the joining table is ignored. 

 merge – fill empty cells of A with B. Values of the current table 
are not changed; empty cells are filled with values of the joining 
table. 

 merge – fill empty cells of B with A. Values of the joining table 
overwrite values of the current table; empty cells of the joining table 
are ignored. 

 keep B only. The column of the joining table replaces the column of 
the current table. 

Preview 
Use the preview table to see whether the result is as expected. Click OK to accept the joint table. 

Edit Feature Values 

Edit the table by clicking into a table cell and modifying the value. Use the Enter (Escape) key to 
accept (discard) your changes. Press the Tab key or the arrow keys to accept changes and move 
the cursor to an adjacent cell. You can use the cut/copy/paste/delete keys to manipulate the table. 

Note: Changing the table does not yet change the underlying samples. You must click 
the Apply button to update samples in the main window. 

Columns Directory (sample path) and Sample (sample name) are read-only. All other columns are 
editable. The possible value for each feature depends on whether it is a numerical, categorical, or 
special feature. See About Samples to learn more about features. 

Edit Selected Samples 

From the top-right panel of the Data Table Editor you can apply some actions to all selected 
samples (table rows). A row counts as selected if any cell in the row is selected. 
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Change Quality Select a value from the drop-down list to assign the value to all 
selected rows. 

Change Usage Select a value from the drop-down list to assign the value to all 
selected rows. 

Load Timestamp Click to automatically assign the value of the Timestamp column. The 
column is added if missing. Existing values will be overwritten. The 
value is read from the sample file content if possible, or from the file 
system otherwise. 

Convert Timestamp to Time 

Click to convert values of column Timestamp (if available) to relative 
time values. A dialog opens which allows you to select a reference 
timestamp for time = 0 and a time unit. All time values will be 
calculated relative to the reference timestamp. 

Remove from Table Click to remove all selected rows from the table. Note that removing 
table rows does not remove samples from the Samples Panel (main 
window) but just from the Data Inspector. 

Edit Features 

From the bottom-right panel of the Data Table Editor you can perform actions to modify features 
(table columns). 

 

Add feature Enter the new feature name in the text field and press the [+] button. 
You can enter regular or special feature names. Put the name in 
braces to make the feature categorical. The name is added to the 
feature list and a new column is added to the table. 
 
Names of regular features are case-sensitive; names of special 
features are not; See About Samples for a list of special feature 
names. If you enter a special feature name it is automatically 
converted to upper case syntax (e.g., Timestamp instead of 
timestamp). 



3 - PEAXACT USER INTERFACE 51 

S o l u t i o n s  f o r  P r o c e s s  A n a l y t i c s  &  C o n t r o l  T e c h n o l o g y  

Remove feature Select a feature from the drop-down list and press the [-] button to 
delete the feature. The corresponding column will be removed from 
the table and from the feature list. 

Show / Hide feature Tick or untick the checkbox of a feature in the feature list to show or 
hide it. Hiding a feature temporarily removes it from the table and 
from graphical plots. 

Rename feature Use the feature list to edit the name if visible or hidden features. You 
can put a name in curly braces to convert a numerical feature to a 
categorical feature. Be careful when removing curly braces from 
feature names because categorical values cannot be converted back 
to numerical values. 
 
Feature names must be unique. If you rename a feature to another 
name in the list, you must decide whether to replace or merge 
column values: 

 
Note: Quality and Usage are reserved names. You can neither 
rename those features nor rename any other feature to a reserved 
name. 

3.6.3 Data Plotter 

The Data Plotter generates customizable graphical reports of sample spectra and features. 
 
The layout of the Data Plotter matches the typical layout of a Report Window (see for a 
description of functionalities common to all Report Windows). This section focuses on specifics of 
the Data Plotter Window. 
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Data Inspector – Data Plotter 

1) Toolbar 
2) Data Table Editor and Data Plotter tabs 
3) Report Panel 
4) Plot Selection Panel 
5) Data Pretreatment Panel 

Available Reports 

 Samples (2D) 
Plot of sample spectra.  
y-axis: signal intensity 
x-axis: spectral axis 
colored by: selectable feature 
 

1 
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3 
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 Samples (3D) 
Plot of sample spectra, arranged along the x2-axis. 
y-axis: signal Intensity 
x1-axis: spectral axis 
x2-axis: selectable feature 
colored by: selectable feature 

 Intensity Surface (2D) 
Heat map of signal intensities. 
x1-axis: spectral axis 
x2-axis: selectable feature 
colored by: signal intensity 
 

 Intensity Surface (3D) 
Surface plot of signal intensities. 
y-axis: signal intensity 
x1-axis spectral axis 
x2-axis: selectable feature 
colored by: signal intensity  
 

 PCA Scores 
Principal component (PC) scores. 
x-axis: score on a selectable PC 
y-axis: selectable feature or another score on selectable PC 
colored by: selectable feature 
 

 PCA Loadings 
Principal component (PC) loadings. 
y-axis: loadings on a selectable PCs 
x-axis: spectral axis 
colored by: sequence 
 

 Correlation Plot  
Correlation of signal intensities with a selectable feature. 
y-axis: correlation in % with a selectable feature 
x-axis: spectral axis 
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 Clusters (Dendrogram) 
Hierarchical cluster tree representing the distance between sample 
spectra. 
y-axis: each tree leaf represents a sample 
x-axis: distance measure between samples 
colored by: selectable feature 

 Features 
Plot of any two sample features. 
y-axis: selectable feature 
x-axis: selectable feature  
colored by: selectable feature 
 

Report Customization 

Plot Configuration 
The Plot Configuration Panel of the Data Plotter contains controls for changing axis variables and 
colors. 

 

1) Select a report. 
2) If available, choose variables for the x-axis and y-axis. Use the sliders to change the visible 

range of values. Use the checkbox to enable/disable the effect of the sliders. 
3) If available, choose a variable for coloration of the plot. 
4) Choose a color scheme. The default colormap depends on the selected report and for 

some reports also on the selected axis variables. 

Note: The actual number of visible and editable configuration controls depends on the 
chosen report. 

Data Pretreatment 
The Data Pretreatment Panel of the Data Plotter contains controls for data manipulations. The 
impact of these settings can directly be previewed in the Report Panel. 

1 

2 

3 
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1) Import Pretreatment Model from active model (main window). 
2) Export to Pretreatment Model of the active model or to new model. 
3) Reset to default Pretreatment Model of the active session profile. 

Pretreatment settings used by the Data Plotter have the same meaning as in the Pretreatment 
Model. However, the Data Plotter keeps its own instance of settings. You can exchange settings 
between the Data Plotter and the active model by using the Import (1) and Export (2) buttons. On 
export you can also choose to create a new model. 

3.7 Modeling 

Modeling is the process of creating a model for analyzing samples. It is subject to the specifics of a 
chosen analysis method. For instance, modeling for peak integration comprises the definition of 
an Integration Model, while Spectral Hard Modeling comprises the creation of a Hard Model. 
 
This section explains modeling functionalities of PEAXACT. See section Analysis to learn more 
about how to use the model for analysis. 

3.7.1 Model 

The term model (without predicate) typically refers to the top-level model container that consists 
of sub-models and that can be saved to a model file. In contrast, sub-models are referred to by 
predicates, e.g., Pretreatment Model. 

Modification 

Properties Panel: Click Model Tree > Model Item 

A model contains a few top-level properties that can be modified with the Model Properties 
Panel: 

Description A free text to describe the model or provide additional information. 

2 3 1 
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Report Directory The suggested default directory for saving reports (e.g., analysis 
results). The directory can be specified as absolute path (starting 
with a drive letter or double slash) or relative path. The latter will be 
resolved to a path relative to the model's directory. For more details 
see Report File. 

See the following section for how to modify the sub-models. 

Undo & Redo 

Menu bar: Edit Model > Undo / Redo 
Hot key: CTRL + Z / CTRL + Y 

Each model keeps a history of its most recent changes (see preferences). You can undo and redo 
these modifications step-by-step. 
 
Undo/Redo is model-specific, i.e., each model has its own history. 

3.7.2 Pretreatment Model 

The Pretreatment Model is a sub-model that provides options for manipulating the sample signal. 
Pretreatments defined by different models never interfere because only the active model’s 
Pretreatments Model manipulated the sample signal, and only temporarily while the model is 
active. 
 
The Pretreatment Model also stores a collection of user-defined Data Filters. A Data Filter 
specifies regions of the sample signal to be used for later operations. The filter only gets applied 
when used in an operation, e.g., during PLS calibration. Otherwise, Data Filters are inactive and 
have no effect. When active though, Data Filters are applied independent from each other to the 
pretreated sample signal, i.e., after all other pretreatments have been carried out. 
 
Pretreatments are carried out before all other operations in the following order: 

• Transformation 

• NMR-specific processing 

• Alignment 

• Resampling 

• Reduction to Global Range 

• Baseline Correction 

• Smoothing / Derivatives 

• Standardization 

• Removal of Excluded Ranges 
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Transformation 

Transformation The option for transforming the signal. 

 None. Disabled 

 Transmittance > Absorbance. Converts transmission to absorbance 
spectra. 
𝐴𝑏 =  −log (𝑇𝑟) 

 % Transmittance > Absorbance. Converts relative transmission 
(given in percent) to absorbance spectra. 
𝐴𝑏 =  −log (𝑇𝑟/100) 

 NMR FID Processing. Applies apodization and zero filling to NMR 
FIDs. 

 NMR FID > Spectrum. Converts NMR FIDs to spectra using 
parameters Spectrometer Frequency (MHz) to convert between time 
and frequency domains, Frequency Shift Mode to specify a reference 
point for the frequency axis (Offset or Center), and Frequency Shift 
(ppm) to specify the x-value of the reference point. If enabled, 
apodization and zero filling are applied to FID, and phase correction 
is applied to the spectrum. 

 NMR FID > Spectrum (mirrored). Same as NMR FID > Spectrum, but 
the spectrum is mirrored horizontally. 

 NMR Spectrum Processing. Applies apodization, zero filling, and 
phase correction to NMR spectra. Because some operations take 
place in the time domain, the Spectrometer Frequency (MHz) must 
be specified to convert between frequency and time domains. 

NMR Apodization The option for apodization of NMR FIDs. 

 None. Disabled 

 Exponential. Exponential apodization using the additional 
parameter Exponential (Hz) for the exponential apodization 
function. 

 Gaussian. Gaussian apodization using the additional parameter 
Gaussian (Hz) for the Gaussian apodization function. 

 Exponential and Gaussian. A combination of both exponential and 
Gaussian apodization. 
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NMR Zero Filling The option for zero filling NMR FIDs to a specified size. The option 
has no effect if the initial FID size already exceeds the specified size. 

 None. Disabled 

 1024 (1k), …, 1048576 (1024k). The total number of data points 
after adding zeros. 

NMR Phase Correction The option for phase correction of NMR spectra. 

 None. Disabled 

 Manual. Manual phase correction using parameters for the Zeroth 
Order and First Order phase in degrees. 

 Auto (Negative Peak Penalization). Automatic adjustment of 
zeroth order and first order phases by an algorithm which minimizes 
negative parts of the mean centered spectrum. 

Modification of X-Values 

Alignment The option for aligning the x-axis with a reference. 

 None. Disabled 

 Reference Peak. Finds the x-position of the largest y-value within a 
specified Reference Peak Range and shifts the x-axis to align the 
reference peak with a specified Target Position. 

Resampling The option for changing the x-resolution by either removing data 
points or by recalculating y-values at new x-values. 

 None. Disabled 

 Thinning. Reduces the number of data points. For a specified 
Thinning Factor of N, every Nth data point is kept. N can be any 
decimal number greater than or equal to 1. 

 Equidistant Points. Resamples data at a specified number of new 
x-values. For a specified Number of Points of N, y-values are 
recalculated at N equally spaced x-values within the visible range by 
linear interpolation. 

 Reference Axis. Resamples data at new x-values loaded from a 
specified sample Reference File. Y-values are recalculated at the 
x-values of the reference sample by linear interpolation. 
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Global Range The global range defines the smallest and largest x-value. Only 
signal in between is considered for analysis. This is useful for cutting 
off unwanted signal at the edges. 

Excluded Ranges Excluded ranges are defined by a lower and upper x-value. Signal in 
between is not considered for analysis. This is useful for cutting off 
local signal artifacts. 

Modification of Y-Values 

Baseline Correction The option to subtract background signal. 

 None. Disabled 

 Offset subtraction. Subtracts a constant value such that the 
smallest value within the reduced spectral range is shifted to zero. 

 Straight line subtraction. Subtracts a straight line from the left-
most to the right-most data point within the reduced spectral range. 

 Linear fit subtraction. Subtracts the straight line that is fitted 
best from below to the signal within the reduced spectral range. 

 Rubber band subtraction. Fits a convex envelope to the spectrum’s 
underside within the full spectral range. 
 
You can specify optional Baseline Nodes to mark points of the signal 
as baseline points. The outer left and right points are nodes by 
default, as well as each point at the edge of an excluded region. Add 
more nodes, e.g., to fit the baseline tighter to a concave part of the 
signal. 

Smoothing / Derivatives The option for smoothing and differentiating the signal to remove 
noise or separate overlapping signals. 

 None. Disabled 

 Smoothing only. Removal of noise by smoothing the signal. A 
Smoothing Filter must be specified that is the number of adjacent 
data points used for smoothing the central point. The greater the 
value, the smoother the signal. 
 
Note: If you have problems getting your data smoothed sufficiently 
even with the maximum filter length, consider using data thinning or 
other resampling options to reduce the total number of data points. 
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 1st order derivative. Numerical first derivation. Inflection points 
in the original signal are resolved to peaks. A Smoothing Filter must 
be specified (see above). 

 2nd order derivative. Numerical second derivation. Shoulders of 
overlapping peaks in the original signal are resolved to peaks. A 
Smoothing Filter must be specified (see above). 

Standardization The option for scaling and shifting the signal. 

 None. Disabled 

 Min-Max normalization. Shifts the minimum y-value to 0 and scales 
the maximum y-value to 1. 

 Area normalization. Shifts the y-center to 0 and scales y-values to a 
mean absolute deviation of 1. 

 SNV normalization. Shifts the y-center to 0 and scales y-values to a 
standard normal variate of 1. 

 Peak normalization. Scales y-values to a specified Reference Peak 
Value which is either the Maximum or the Area of a reference peak. The 
reference peak is defined by the following properties: 
Reference Peak Range: The lower and upper bound of the x-region of 
the reference peak. The peak value is calculated from data within 
this region. 
Reference Peak Baseline: The baseline type of the reference peak. 
For some types you can specify optional baseline ranges. 
Lower Baseline Range: The lower and upper bound of the lower x-
region that is used to find the baseline. 
Upper Baseline Range: The lower and upper bound of the upper x-
region that is used to find the baseline. 

3.7.2.2 Modify Pretreatments 

Properties Panel: Click Model Tree > Data Pretreatment Item 

The Pretreatment Model can be modified by using the Model Properties Panel. 
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Interactive Modification of Excluded Ranges 

New excluded ranges can be added via the context menu of the Plot Panel. Use the mouse to 
interactively modify bounds of excluded ranges (see preferences). Drag the gray area with the left 
mouse button to shift the whole range. Drag the boundary line to modify the boundaries. Right-
click the area to open the context menu for more options. 

 

Interactive Modification of Rubber Band Baseline Nodes 

If Baseline Correction is set to Rubber Band Subtraction, new baseline nodes can be added via 
the context menu of the Plot Panel. Use the mouse to modify baseline nodes. Drag the black 
circle with the left mouse button to shift the position of the node. Right-click the circle to open 
the context menu for more options. 
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Interactive Modification of Reference Peak for Normalization 

If Standardization is set to Peak Normalization, the reference peak for normalization is displayed 
in the Plot Panel. Use the mouse to modify the reference peak. Drag the colored area with the left 
mouse button to shift the whole peak. Drag the vertical dashed lines or the arrows to modify the 
left or right boundaries. Drag the dotted lines (if available) to modify the left or right baseline 
regions. Hold the SHIFT key and drag the dash-dotted lines (if available) to create baseline 
regions. 

 

3.7.2.3 Reset to Defaults 

Menu bar: Edit Model > Pretreatment Model > Reset 
Context Menu: Model Tree > Pretreatment Item > Reset 

Resets the Pretreatment Model to defaults defined in the active session profile. This does not 
affect Data Filters. 

3.7.2.4 Add Data Filter 

Menu bar: Edit Model > Pretreatment Model > Add Data Filter… 
Context Menu: Model Tree > Pretreatment Item > Add Data Filter… 
Context Menu: Plot Panel > Add Data Filter 

Adds a new Data Filter to the Pretreatment Model. A dialog gets shown to specify the name of 
the new filter. Data Filters can get any name if it is unique within the Pretreatment Model. 
 
A Data Filter added this way has no ranges specified. Modify the ranges, either manually using 
the Properties Panel, or interactively using the Data Filter Tool. 

Adding Data Filters via Plot Panel 

Context Menu: Plot Panel > Add Data Filter 

Right-click at the desired position in the Plot Panel and select Add Data Filter from the context 
menu. The new Data Filter gets a default name and has one range specified around the clicked 
point. 
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Modify the ranges, either manually using the Properties Panel, or interactively using the Data 
Filter Tool. 

Adding Data Filters via Data Filter Tool 

Toolbar:  

Enable the Data Filter Tool and make sure that no existing Data Filter is selected in the Model 
Tree Panel. Left-click at the desired position in the Plot Panel and move the mouse while holding 
the mouse button pressed. This adds a new Data Filter with default name. 

3.7.2.5 Rename Data Filter 

Menu bar: Edit Model > Pretreatment Model > Rename Data Filter… 
Context Menu: Model Tree > Data Filter Item > Rename… 

Renames the selected Data Filter. Data Filters can get any name if it is unique within the 
Pretreatment Model. 

3.7.2.6 Remove Data Filter 

Menu bar: Edit Model > Pretreatment Model > Remove Data Filter 
Context menu: Model Tree > Data Filter Item > Remove 
Context menu: Plot Panel > Data Filter Item > Remove 

Removes the selected Data Filter. 
 
Removing Data Filters may affect other model elements which depend on them, e.g., the 
Calibration Model. 

3.7.2.7 Modify Data Filter 

Changing Parameter Values 

Select the Data Filter item in the Model Tree Panel to display the element's parameters in the 
Properties Panel. Use the table in the Properties Panel to change parameter values. 

Modifying Data Filters Interactively 

In the Plot Panel you can use the mouse to interactively modify ranges of the selected Data Filter. 
Drag a highlighted line segment with the left mouse button to shift the range. Drag the arrows to 
modify the left or right range boundary. 
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Enable the Data Filter Tool  to get more modification options. Left-click and drag the mouse 
while the button is pressed to add or subtract ranges. Right-click to open the context menu for 
more options, e.g., toggle between add and subtract mode. 

 

3.7.3 Integration Model 

The Integration Model is a sub-model that consists of components, each containing one or more 
peaks specifying integration limits and a baseline for calculating the area under the sample signal. 
 
Integration models can be utilized for Integration and, when combined with a Calibration Model, 
for Prediction. 

3.7.3.1 Remove Integration Model 

Menu bar: Edit Model > Integration Model > Remove 
Context menu: Model Tree > Integration Model Item> Remove 

Removes the whole Integration Model. Removing the Integration Model may affect other model 
elements which depend on it, e.g., the Calibration Model or Custom Results. 

3.7.3.2 Add Peak 

Toolbar:  
Menu bar: Edit Model > Integration Model > Add Peak… 
Context menu: Model Tree > Integration Model Item > Add Peak… 
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Adds a new Integration Model Peak to either an existing component or a new component of the 
active model. A dialog gets shown to specify properties of the new peak. 

 

Component The component to which the peak should be added. Either select an 
existing component from the drop-down list or enter a new 
component name. Components can get any name if it is unique 
within the Integration Model. 

Lower/Upper limit X-values of the lower and upper integration limit. 

Baseline The type of the baseline to be subtracted from the signal. Some 
baseline types support the definition of separate baseline regions. 
The following baseline options are available: 

 None. The baseline is zero. This option does not support baseline 
regions 

 Minimum Offset. The baseline is a constant which is the smaller of 
the two values calculated from the left and right baseline regions. 
The calculated value is the mean signal (y-values) within each 
baseline region, or, for any unspecified region, the y-value at the 
closest integration limit. 

 Mean Offset. Like Minimum Offset, but the constant is the mean of 
the two calculated values. 
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 Straight Line. The baseline is a straight line between two points 
calculated from the left and right baseline regions. The calculated 
points are the center (x-values) and mean signal (y-values) within 
each baseline region, or, for any unspecified region, the signal x- and 
y-values at the closest integration limit. 

 Linear Fit. The baseline is a straight line fitted from below to the 
signal within the specified integration limits. However, the actual 
integration limits are then defined by the two points where the 
straight line touches the signal. This option does not support 
baseline regions. 

BL region 1 start/stop X-values of the region defining the left point of the baseline. Any 
empty value defaults to the lower integration limit. 

BL region 2 start/stop X-values of the region defining the right point of the baseline. Any 
empty value defaults to the upper integration limit. 

Use the preview at the bottom of the dialog to evaluate your settings. Clicking OK adds the new 
peak to the Integration Model. 
 
Adding peaks may affect other model elements which depend on the Integration Model, e.g., the 
Calibration Model or Custom Results. 

Adding Peaks via Plot Panel 

Context menu: Plot Panel > Add Peak (Integration Model) 

Right-click at the desired peak position in the Plot Panel and select Add Peak (Integration 
Model) from the context menu. The new peak has integration limits around the clicked point and 
a default baseline. 
 
New peaks are added to the selected Integration Model Component, or, if no component is 
selected, to a new component with a default name. 

3.7.3.3 Move Peak 

Menu bar: Edit Model > Integration Model > Move Peak to > … 
Context menu: Model Tree > Integration Model Peak Item > Move to > … 
Context menu: Plot Panel > Integration Model Peak Plot > Move to > … 

Moves the selected Integration Model Peak to either another component or to a new component. 
Choose the target component and, if it is a new component, enter the new component name. 
Components can get any name if it is unique within the Integration Model. 
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Moving peaks may affect other model elements which depend on the Integration Model, e.g., the 
Calibration Model or Custom Results. 

3.7.3.4 Remove Peak 

Menu bar: Edit Model > Integration Model > Remove Peak 
Context menu:  Model Tree > Integration Model Peak Item > Remove 
Context menu: Plot Panel > Integration Model Peak Plot > Remove 

Removes the selected Integration Model Peak. You can remove any peak from any component 
and potentially leave empty components without peaks. Empty components always have a 
component area of zero.  
 
Removing peaks may affect other model elements which depend on the Integration Model, e.g., 
the Calibration Model or Custom Results. 

3.7.3.5 Rename Component 

Menu bar: Edit Model > Integration Model > Rename Component… 
Context menu: Model Tree > Integration Model Component Item > Rename… 
Properties Panel: Click Model Tree > Integration Model Item 

Renames the selected Integration Model Component. Components can get any name if it is 
unique within the Integration Model. 

3.7.3.6 Remove Component 

Menu bar: Edit Model > Integration Model > Remove Component 
Context menu: Model Tree > Integration Model Component Item > Remove 

Removes the selected Integration Model Component. Removing components may affect other 
model elements which depend on the Integration Model, e.g., the Calibration Model or Custom 
Results. 

3.7.3.7 Adjust Parameters 

Changing Parameter Values 

Select the Integration Model item in the Model Tree Panel or its graphical representation in the 
Plot Panel to display the element's parameters in the Properties Panel. Use the table in the 
Properties Panel to change parameter values. 

Modifying Peaks Interactively 

In the Plot Panel you can use the mouse to interactively modify the bounds of an Integration 
Model Peak. Drag the colored area with the left mouse button to shift the whole peak. Drag the 
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vertical dashed lines or the arrows to modify the left or right integration limits. Drag the dotted 
lines (if available) to modify the left or right baseline regions. Hold the SHIFT key and drag the 
dash-dotted lines (if available) to create baseline regions. Right-click the area to open the context 
menu for more options. 

 

3.7.4 Hard Model 

The Hard Model is a sub-model that consists of peak functions to represent a sample spectrum in 
a physically meaningful way. E.g., peak functions can overlap, shift, and change shape as 
observed in real spectra because of chemical and physical molecular interactions. 
 
Hard Models can be utilized for Hard Modeling Factor Analysis, Component Fitting, and, when 
combined with a Calibration Model, for Prediction. 

Nomenclature 

When working with Hard Models, you should be familiar with the following wording: 

Hard Model 
A Hard Model in general is a mathematical function which is derived from equations representing 
the physics behind an underlying process. In PEAXACT, the term Hard Model refers to a function 
derived from the physics of molecular spectroscopy; it is a mathematical representation of a 
spectrum or a Spectral Hard Model. 
 
Physics tells us that a mixture spectrum is composed of superimposed peaks originating from the 
individual components in the mixture, with the components' concentrations being responsible for 
the peaks' intensities. This structural information is maintained in the Hard Model by means of a 
sum of peak-shaped curves. Subsets of peak-curves that represent pure component spectra are 
referred to as component models or Hard Model Components; they are multiplied by 
concentration-related weight parameters. 
 
In summary, the Hard Model consists of weighted (Hard Model) Components which again consist 
of (Hard Model) Peaks. The Hard Model is completed by a simple baseline function. 

Hard Model Component 
The (Hard Model) Component is a mathematical representation of a pure component spectrum. It 
consists of (Hard Model) Peaks and has an associated component weight. 
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Hard Model Peak 
The (Hard Model) Peak is a mathematical function with a peak-shaped profile. PEAXACT uses 
pseudo-Voigt functions. A pseudo-Voigt function is a linear combination of Gaussian and 
Lorentzian functions. 

Component Weight 
The component weight is the most important parameter of the Hard Model. Each Hard Model 
Component has an associated component weight parameter which represents the quantity of 
that component, i.e., component weights correspond to concentrations and therefore are 
relevant parameters for calibration. Component weights are determined automatically when 
fitting the Hard Model to samples. 

Peak Parameters 
Peak parameters are the parameters of Hard Model Peak, e.g., the position or width. Peak 
parameters can be set manually but are typically determined automatically by fitting the Hard 
Model to samples. 

Editable Component & Editable Peaks 
The first Hard Model Component is the editable component because peaks can only be added, 
removed, or modified in this component. Accordingly, peaks of the editable component are called 
editable peaks. 

Model Fitting, Peak Fitting & Component Fitting 
Model fitting is a general expression for a mathematical procedure in which the model’s 
parameters are automatically adjusted until the model fits a certain measured spectrum. Peak 
fitting and component fitting are special kinds of model fitting which differ in the parameters 
being adjusted. Peak fitting refers to the adjustment of peak parameters of only the editable 
peaks. Component fitting mainly refers to the adjustment of component weights. Errors in 
component weights can be reduced by simultaneously adjusting peak parameters to account for 
peak variations in the measured spectrum. The extent of peak adjustments during component 
fitting is controlled by Hard Model settings. 

3.7.4.2 New Hard Model 

Menu bar: Edit Model > Hard Model > New… 
Context menu: Model Tree > Hard Model Item > New 

Adds a Hard Model to the active model. Use the dialog to specify the name of the first Hard 
Model Component. The first component of each Hard Model is also known as the editable 
component because new Hard Model Peaks can only be added, removed, and modified for this 
component. 
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Name of Editable Component 

If your intention is to add peaks, consider naming the editable component after the pure 
component to be modeled. If you only intend to import other components, consider keeping the 
default name as the editable component is not relevant in this case. You can always rename 
components later. 
 
If a sample is active while the new Hard Model is being created, the name of the editable 
component is suggested to be the sample name. 

New Hard Model for Active Sample 

Context menu: Samples Panel > New Hard Model for Active Sample 

When creating a Hard Model from the context menu of the Samples Panel the first component is 
automatically named after the active sample. If the currently active model already has a Hard 
Model, or if no model is active at all, a new model is created first. 

New Hard Model If Required 

Some hard modeling operations automatically prompt you to create a new Hard Model if none 
exists, e.g., when adding Hard Model Peaks or importing Hard Model Components. 

3.7.4.3 Remove Hard Model 

Menu bar: Edit Model > Hard Model > Remove 
Context menu: Model Tree > Hard Model Item > Remove 

Removes the whole Hard Model. Removing the Hard Model also removes dependent elements 
such as Component Fits or the Calibration Model. 
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3.7.4.4 Add & Autofit Peaks 

Toolbar:  
Menu bar: Edit Model > Hard Model > Add & Autofit Peaks… 
Context menu: Model Tree > Hard Model Item > Add & Autofit Peaks… 
Context menu: Model Tree > First Component Item > Add & Autofit Peaks… 

Auto-fitting of Hard Model Peaks is a combination of adding new peaks to the editable 
component and automatically adjusting editable peaks such that the model fits the active sample 
spectrum. 
 
You are prompted to enter the number of new peaks. Start with a rough count of peaks in the 
sample and add more peaks later if required. 

 

Note: New peaks will always be added to the editable component. 

The peak fitting algorithm is controlled by model settings. In general, first the position of the next 
peak to be added is determined by analyzing the spectral residuals, then a new Hard Model Peak 
is added to the editable component, and finally the model is fitted to the active sample according 
to the peak fitting procedure. 

3.7.4.5 Remove Selected Peaks 

Menu bar: Edit Model > Hard Model > Remove Selected Peaks 
Context menu: Model Tree > Hard Model Peak Item > Remove  
Context menu: Plot Panel > Hard Model Peak Plot > Remove 

Removes selected peak from the editable component. You can also select a peak in the Model 
Tree Panel or its graphical representing in the Plot Panel and press the Delete key. 

3.7.4.6 New Component from Selected Peaks 

Menu bar: Edit Model > Hard Model > New Component from Peaks… 
Context menu: Model Tree > Hard Model Peak Item > New Component…  
Context menu: Plot Panel > Hard Model Peak Plot > New Component… 

Moves selected peaks from the editable component to a new component. You are prompted to 
enter the new component’s name. 
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3.7.4.7 Import Components 

Toolbar:  
Menu bar: Edit Model > Hard Model > Import Components… 
Context menu: Model Tree > Hard Model Item > Import Components… 
Drag & Drop: from Explorer to Model Tree Panel 

The File Dialog can be used to browse directories and select one or more model files to import 
Hard Model Components from. Choose a file filter from the drop-down list to localize certain 
model files. A model must be active to import components. 
 
All non-empty components of the source models are copied to the active model. If no Hard Model 
exists yet, you will be prompted to create one first. 
 
Names of imported components that already exist will automatically be numbered consecutively. 

Drag and Drop 

A fast way to import Hard Model Components is by using drag & drop. Activate the target model 
in the Model Tree Panel, then drag model files from the Windows Explorer, e.g., and drop them 
into the Model Tree Panel. You will be asked whether to open these files or to import components 
into the active model. 

 

Component Equilibration 

Imported Hard Model Component are equilibrated, which means that 

• component weights are set to 1, and 

• peak amplitudes of each component are scaled such that the maximum peak amplitude is 
in the same order of magnitude as the active sample (or 1 if no sample is active) 
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Component equilibration is reasonable because otherwise parameters of different components 
could have totally different orders of magnitude. 

Caution: Do not import components while a sample is active which is completely 
unrelated to the Hard Model. 

3.7.4.8 Rename Components 

Menu bar: Edit Model > Hard Model > Rename Component… 
Context menu: Model Tree > Hard Model Component Item > Rename 
Properties Panel: Click Model Tree > Hard Model Item 

Renames the selected Hard Model Component. Components can get any name if it is unique 
within the Hard Model. 

3.7.4.9 Remove Components 

Menu bar: Edit Model > Hard Model > Remove Component 
Context menu: Model Tree > Hard Model Component Item > Remove 

Removes the selected Hard Model Component. Removing components may affect other model 
elements which depend on the Hard Model, e.g., the Calibration Model or Custom Results. 

Note: You cannot remove the editable component. 

3.7.4.10 Export Components 

Menu bar: Edit Model > Hard Model > Export Component 
Context menu: Model Tree > Hard Model Component Item > Export… 

Exports the selected Hard Model Component to a new model file. The new model will contain a 
Hard Model with just the one component. In addition, the Pretreatment Model is copied to the 
new model too. The File Dialog can be used to browse directories and select or enter a filename 
for the model to be saved. By default, the component name is suggested as filename. 
 
Exporting of components is not required if the Hard Model only contains a single component. In 
that case, simply save the model. 

Overwriting Existing Files 

As a precaution, you cannot save the model to a file of another model that is currently opened in 
PEAXACT. You must close the other model before overwriting its file. 
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3.7.4.11 Adjust Parameters Manually 

Manual modification of Hard Model parameters becomes reasonable when automatic parameter 
adjustment does not work as expected. Then, minor manual modifications could remedy these 
modeling problems. However, manual adjustments should always be followed by automatic 
parameter fitting to further improve the model. 

Changing Parameter Values 

The following parameter values can be modified manually using the Model Tree Panel: 

• all baseline parameters 

• peak parameters of the editable component 

The following parameters cannot be modified manually: 

• component parameters (component shift and component weight) 

• peak parameters of other components than the editable component 

Select the Hard Model item in the Model Tree Panel or its graphical representation in the Plot 
Panel to display the element's parameters in the Properties Panel. Use the table in the Properties 
Panel to change parameter values. 

Fixing Parameters 

All model parameters but component weights can be fixed, which means that parameter values 
are not allowed to get changed during model fitting. Still, parameters can get changed manually. 
 
Select the model item in the Model Tree Panel or its graphical representation in the Plot Panel to 
display the element's parameters in the Properties Panel. Use the check boxes in the Properties 
Panel to fix or free parameter values. Baseline parameters and peak parameters can also be fixed 
all at once from the element's context menu. 

Important note: The position of Hard Model Peaks is influenced by two parameters: the 
peak position parameter and the component shift parameter. While the former is 
individual for each peak, the latter is the same for all peaks of a component. Fix both 
parameters if you do not want Hard Model Peaks to get shifted. 

Fixing parameters is useful for reducing model complexity (because less parameters need to be 
adjusted during model fitting), but at the same time model flexibility is reduced too, because less 
peak variations in the sample can be explained by the model. 

Adding Peaks 

Context menu: Plot Panel > Add Peak (Hard Model) 

To add a Hard Model Peak manually, right-click at the desired peak position in the Plot Panel and 
select Add Peak (Hard Model) from the context menu. The new Hard Model Peak has its position 
and maximum at the clicked point and gets suggested values for the other peak parameters. 
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Note: New peaks will always be added to the editable component. 

Removing Peaks 

Menu bar: Edit Model > Hard Model > Remove Selected Peaks 
Context menu: Model Tree > Hard Model Peak Item > Remove 
Context menu: Plot Panel > Hard Model Peak Plot > Remove 

You can remove currently selected Hard Model Peaks. Select a Hard Model Peak in the Model 
Tree Panel or its graphical representing in the Plot Panel first. In the Plot Panel you could even 
select multiple peaks while the SHIFT key is pressed. 
 
Only peaks of the editable component can be removed. 

Modifying Peaks Interactively 

Peaks models can be modified interactively by using the mouse: 

• Height and position: Grab the top of an editable peak plot and move the mouse up / down 
to change the height and move it to the right / left to change the position 

• Width: Grab one side of an editable peak plot and move the mouse to the right / left 

 

Caution: You should always respect specified constraints for the peak width parameter 
when modifying peaks manually. Otherwise, model fitting might not work as expected 
or might not work at all. 

Grouping Peaks 

Context menu: Plot Panel > Peak Plot > Peak Grouping > Group / Ungroup 

Grouped peaks behave like a single new peak with new shape. Select two or more peak plots in 
the Plot Panel (left-click on the plots while the SHIFT key is pressed) and then right-click on one of 
the plots to open the context menu. From the context menu you could either add all selected 
peaks to a new group or release peaks from the group. When clicking on a grouped peak in the 
Plot Panel, the whole group is selected. When clicking on a grouped peak in the Model Tree 
Panel, only the clicked peak is selected. 
 
Because of the following impacts, peak grouping is relevant for component fitting only: 
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• The intensity (peak area) of grouped peaks is kept constant as a sum, instead of for each 
peak individually (see also: Fitting Options). 

• If a parameter (e.g., position) of any peak is considered for automatic adjustment, the 
same kind of parameter will be fitted for all peaks in the group. 

Peak grouping is particularly useful to model asymmetric measured peaks by multiple symmetric 
Hard Model Peaks. 

Caution: Peak grouping should only be used for fine tuning the model. 

Switching Baseline Polynomial between Linear and Quadratic 

Context menu: Model Tree > Hard Model Baseline Item > Quadratic Baseline 
Context menu: Plot Panel > Hard Model Baseline Plot > Quadratic Baseline 

The Hard Model Baseline can be a linear or quadratic polynomial. The linear baseline has two 
parameters (offset and slope), the quadratic baseline has three parameters (offset, slope, and 
quadratic factor). 
 
The Hard Model Baseline should be as simple as possible because it is partly redundant to 
baseline corrections specified in the Pretreatment Model.  

Consider using pretreatments such as range selection and baseline correction to 
remove background signal, before switching to a quadratic Hard Model Baseline. 

Modifying Baseline Interactively 

If the Hard Model Baseline is displayed as a separate plot in the Plot Panel (see preferences), it 
can be modified interactively by using the mouse. In case of a linear function: 

• Offset: Grab the center of the baseline plot and move the mouse up / down 

• Slope: Grab the left or right fifth of the baseline plot and move the mouse up / down 

 

In case of a quadratic function, baseline parameters are determined by means of three points the 
baseline goes through. You can adjust the baseline parameters by moving these three points: 

• Center point: Grab the center of the baseline plot and move the mouse in any direction 

• Leftmost point, rightmost point: Grab the left or right fifth of the baseline plot and move 
the mouse up / down 
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3.7.4.12 Adjust Parameters Automatically 

Toolbar:  
Menu bar: Edit Model > Hard Model > Adjust Editable Peaks 

Toolbar:   
Menu bar: Edit Model > Hard Model > Adjust Components > … 

The model's parameter can be adjusted automatically such that the model fits a certain measured 
spectrum. Model fitting is a crucial step because the Hard Model is intended to represent a 
mixture spectrum well. A good fit will provide good initial parameter values for subsequent 
analyses. 
 
There are two kinds of model fitting: peak fitting and component fitting. They differ in parameter 
constraints being applied and in the set of parameters being adjusted. 

Peak Fitting 

Peak fitting is suited for creating new Hard Models from the scratch. It is an unconstrained fit 
(except for bounds on peak width and shape parameters) of editable peaks and therefore it is 
qualified for making major parameter adjustments, e.g., when adding or removing peaks. 
 
In detail, peak fitting covers: 

• adjustment of all parameters of all editable peaks 

• adjustment of baseline parameters 

• adjustment of component weights 

Component Fitting 

Component fitting is suited for fine tuning parameters of an existing Hard Model. It is a fit of 
component weights, but other parameters can be adjusted too according to the chosen 
parameter set. These additional parameters are fitted with respect to tight constraints. Peak 
parameters can only vary with respect to constant peak intensities (peak areas). Because of these 
constraints, component fitting is only qualified for moderate parameter adjustments. 

Note: Component fitting is also performed during some analyses, but while the analysis 
never changes the Hard Model, during modeling the Hard Model is changed such that 
adjusted parameter values become new initial values. 

Adjusting model parameters by means of component fitting is often not necessary, though in 
some cases it can be reasonable to get better initial parameter values. 

Repeated Model Fitting 

When conducting peak fitting or component fitting repeatedly it is likely you will see the fit 
improving slightly each time. There are several reasons for this, e.g.: 
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• Stopping criteria for model fitting are measured relative to the starting point. The starting 
point of each new fit is the previous fit. 

• Relative parameter bounds might be reached during one fit. Each new fit has new bounds. 

Caution: Repeated component fitting might significantly deform peaks. This could 
even result in poorer initial parameter values. 

3.7.4.13 Settings for Hard Model Fitting 

Hard Model fitting is affected by several settings explained in this section. 

Peak Fitting 

Default Peak Type The default peak function used when adding new peaks to the Hard 
Model. 

 Pseudo-Voigt. The Pseudo-Voigt function is a linear combination of 
Gaussian and Lorentzian functions: 

𝑃 = 𝛼 [𝛽 ∙ exp (− ln(2)
(𝑥 − 𝛿)2

𝛾2
) + (1 − 𝛽)

𝛾2

(𝑥 − 𝛿)2 + 𝛾2
] 

α = peak maximum at the peak’s center position  
β = Gaussian-Lorentzian-ratio between 0 and 1 
γ = half width at half maximum (HWHM) 
δ = center position 
x = independent variable 
The area under the peak curve is: 

𝐴 = 𝛼 ∙ 𝛾 [
𝛽

√ln(2) 𝜋⁄
+ (1 − 𝛽)𝜋] 

Auto-Fit Mode The mode for adding and fitting new peak functions. 

 Regular (Sequential). Peak functions are added and fitted one by 
one. The next peak function will be added at the position of the 
largest positive difference between model and signal. This method is 
slow because all peaks are fitted every time a new peak is added, but 
sometimes this leads to a better accuracy of the final fit. 

 Fast (Simultaneous). Peak functions are added and fitted in 
groups. Peak positions are determined by means of a peak search. 
This method is fast and often leads to more physically reasonable 
results. 

Weighted Auto-Fit The option for dealing with noise and peaks of different orders of 
magnitude when adding and fitting peak functions. 
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 Enabled. Residuals between model and sample are weighted by the 
absolute sample intensity to consider that noise typically scales with 
signal intensity, i.e., the noise of a large peak might even be larger 
than small residual peaks. This way, "noisy peaks" are suppressed, 
and the next Hard Model Peak is more likely to be added at the 
position of a real peak. 

 Disabled. The next peak function is added at the position of the 
largest positive difference between model and sample. 

Absolute Parameter Constraints 
Absolute parameter constraints limit values of Hard Model parameters when being adjusted 
automatically during model fitting. However, parameter constraints can easily be violated by 
manually setting parameter values outside the constrained range or by tightening constraints 
such that previous model parameters are then out of bounds. Make sure to not accidentally 
violate parameter constraints manually. 

Caution: Model fitting may not work correctly for Hard Models with violated parameter 
constraints. 

HWHM Absolute lower and upper bounds for the HWHM (half width at half 
maximum) parameter. 

Gaussian Part Absolute lower and upper bounds for the peak’s Gaussian part 
parameter. 

Component Fitting 

Component fitting, in general, refers to the adjustment of Hard Model Components to fit a 
spectrum. Options in this section affect how component fits are performed. However, options are 
ignored in the following special cases where component fitting is also performed: 

• HMFA: here, only weights and baseline parameters are fitted 

• Automatic parameter adjustments during hard modeling: here, component fitting is 
controlled by a separate choice of parameters (see Adjust Components) 

Fitting Mode The fitting mode controls the extent of model flexibility, i.e., groups 
of free model parameters for component fitting.  
 
Component fitting modes are named after the main cause for peak 
variations, namely the extent of molecular interactions among 
chemical components in a mixture. 
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 Minimal Interaction. Only component weights (W) and baseline (B) 
parameters are adjusted. This is a linear fit and thus very fast. If the 
Component Shift option is enabled (see below), the fit becomes 
nonlinear. 

 Medium Interaction. WB parameters and individual peak positions 
are adjusted. The actual number of individual peaks being shifted is 
controlled by the No. of Considered Peaks setting (see below). 

 High Interaction. WB parameters and all peak parameters are 
adjusted. The actual number of individual peaks being shifted and 
deformed is controlled by the No. of Considered Peaks setting (see 
below). 

 Maximal Interaction. All model parameters are adjusted 
simultaneously. This fit is very time-consuming and can only be 
recommended for very small models, e.g., if each component only 
has 1 peak. In that special case the fit may even be faster and result 
in a smaller fitting error than other modes. 

Component Shift This setting can be combined with Fitting Mode to enable or disable 
component shifts. You may use this option to correct for 
component-wise misalignments. However, consider using the 
Alignment option of the Pretreatment Model instead if possible. 

 No. Disabled 

 Yes. Components get shifted independently of each other as a first 
step of component fitting. When enabled, the Properties Panel (of 
the Hard Model item) displays an extra table column to enable or 
disable shift parameters on a component basis. 

No. of Considered Peaks This setting only takes effect if component fitting modes medium 
interaction or high interaction are selected. In both cases, the 
number of adjusted peaks is limited by this setting. The fitting 
algorithm only considers the most important peaks, i.e., peaks which 
have the largest influence on improving the fit. Increasing the 
number of considered peaks increases computational time but does 
not necessarily increase the goodness of the fit because insignificant 
peaks might get fitted too. As a rule of thumb, the number of 
considered peaks should be as high as the number the 
significant/large peaks in the model. 
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Component Weight Threshold 
Hard Model Components with a component weight below the 
threshold will not be adjusted during component fitting to prevent 
tiny peaks from getting shifted around and fit noise. The threshold 
value applies if one would scale the model to a maximum y-value of 
1. The threshold value could then be interpreted as a fraction of 1. 

Relative Parameter Constraints 
Relative parameter constraints define how much a parameter can vary relative to its starting 
value. Absolute parameter constraints (see above) will still be honored though. 

Component Shift Relative bounds (in parameter units) for the component shift 
parameter. This option is hidden if Component Shift (see above) is set 
to No. 

Position Relative bounds (in parameter units) for the peak position 
parameter. 

Max Relative bounds (in percent) for the peak maximum parameter. 

HWHM Relative bounds (in percent) for the peak HWHM parameter. 

Gaussian Part Relative bounds (in parameter units) for the peak’s Gaussian part 
parameter. 

Constant Peak Intensity This constraint results from the physical observation, that for a 
constant concentration, the peak intensity (peak area) is constant 
even if the peak shape changes, e.g., due to molecular interactions. 
Therefore, peak shape parameters (maximum, HWHM, and Gaussian 
Part) are coupled. This should be considered when changing relative 
constraints for these parameters. 

Optimizer Options 

Optimizer options are for advanced tuning and should be modified by experienced users only. 

Linear Fitting 

Linear fitting options apply to component fitting (Minimal Interaction) and HMFA. It is 
recommended not to change the default settings. 

Max. Iterations Stopping criterion. Optimization stops after a maximum number of 
iterations. 
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Objective Function Tolerance 
Termination tolerance. Optimization stops only if objective function 
value drops below the tolerance. The value should be between 1e-10 
and 1e-15. 

Nonlinear Fitting 

Nonlinear fitting options apply to peak fitting and component fitting (Medium Interaction to 
Maximal Interaction). 

Max. Iterations Stopping criterion. Optimization stops after a maximum number of 
iterations. 

Objective Function Tolerance 
Termination tolerance. Optimization stops only if objective function 
value drops below the tolerance. The value should be around 1e-6. 

Parameter Tolerance Termination tolerance. Optimization stops only if progress in 
improving parameters drops below tolerance. The value should be 
around 1e-6. 

Constrained Fitting Algorithm 
This option only applies to constrained optimization problems, i.e., 
component fitting with High Interaction or Maximal Interaction. 

 Active-set. Moderate progress during all iterations. This algorithm 
typically stops due to small progress. Default termination tolerances 
should be used. 

 SQP. Thorough optimization. Good progress at the beginning, 
steady progress at the end. This algorithm typically stops when the 
maximum number of iterations is reached. Therefore, the maximum 
number of iterations should be chosen carefully. 

Constraint Violation Tolerance 
Termination tolerance. Optimization stops only if constraints are 
violated by less than the tolerance. The value should be around 1e-2. 
This option only applies to constrained optimization problems, i.e., 
component fitting with High Interaction or Maximal Interaction. 

Modification 

Properties Panel: Click Model Tree > Hard Model Item > Left-click toggle button 

Hard Model settings can be modified by using the Model Properties Panel. Select the Hard Model 
item or any of its sub-items in the Model Tree Panel and then left-click the toggle button in the 
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Model Properties Panel. The button toggles between Hard Model parameters and Hard Model 
settings. 

 

1) Toggle between Hard Model parameters view and Hard Model settings view 

Reset 

Context menu: Click Model Tree > Hard Model Item > Right-click toggle button 

Hard Model settings can be reset to preferences defined in the active session profile. Right-click 
the toggle button and choose Reset from the context menu. 

3.7.5 Calibration Model 

The Calibration Model is a sub-model that is a functional relationship between values calculated 
from sample spectra (e.g., component weights) and numerical features (e.g., concentrations). 
The functional relationship is established by regression. 
 
Calibration Models can be utilized for Prediction. 

3.7.5.1 New Calibration Model 

Toolbar  
Menu bar: Edit Model > Calibration Model > New… 
Context menu: Model Tree > Calibration Model Item > New… 

Creates a new Calibration Model and adds it to the active model, replacing a previous Calibration 
Model if any. 
 
Calibration is performed with selected samples except for those with Quality set to bad. Samples 
with Usage set to train are used for training the Calibration Model. Training samples must provide 
at least one numerical feature. Samples with Usage set to test are used for validating the 
Calibration Model. Samples with Usage set to ignore have no effect on calibration or validation but 
are still included in reports.  
 
Calibration begins with a setup dialog. Results are then displayed in a Report Window where you 
can evaluate the alternative Calibration Models. Finally, you must choose and accept one 
alternative. 

1 
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Calibration Setup 

 
Calibration Setup Dialog for univariate (left) and multivariate calibration (right) 

Calibration Method The algorithm to be used for calibration. Depending on your choice, 
the Calibration Setup Dialog changes its appearance to provide 
proper controls for each method. The following options are 
available: 

 Peak Integration (PI) Regression. Univariate regression of feature 
values on Integration Model Component areas; requires an 
Integration Model. 

 Hard Modeling (HM) Regression. Univariate regression of feature 
values on Hard Model Component weights; requires a Hard Model. 

 Partial Least Squares (PLS) Regression. Multivariate regression 
of feature values on spectral intensities. PEAXACT creates separate 
regressions for each feature (also known as PLS-1) using the SIMPLS 
algorithm. 
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Predictive Features The table shows a list of available numerical features and for each 
the number of available samples with Usage = train, test, and 
ignore. Use the checkboxes to activate/deactivate features for 
calibration. 
 
For PI, each active feature must be linked with an Integration Model 
Component in order to provide a connection between features and 
component areas. 
 
For HM, each active feature must be linked with a Hard Model 
Component in order to provide a connection between features and 
component weights. 
 
For PLS, an active feature can optionally be linked with a Data Filter 
in order to calibrate separate features with separate regions of the 
spectrum. It is possible to link the same Data Filter to multiple 
features. If no Data Filter is assigned, the whole spectrum is used. 

Regression Settings 

Regression variables A method-dependent modifier that specifies how regression 
variables should be treated. The following options are available: 

 normal. Available for univariate regression (PI, HM); regression of 
the Calibration Model is performed separately for each feature. 

 ratios. Available for univariate regression (PI, HM) if the sum of 
active feature values is the same constant for all sample; regression 
of the Calibration Model is done for pairwise ratios of features and by 
incorporating the closure constant. 

 centered. Available for PLS regression; each data point of the 
spectrum is centered at the mean across all training samples. 

 centered + scaled. Available for PLS regression; data points are 
centered, followed by division of each data point by the standard 
deviation across all training samples. 

Maximum function Available for univariate regression (PI, HM); The maximum 
polynomial degree of the regression function to establish the 
functional relationship between component areas / weights and 
numerical features. A separate model will be calibrated for each 
function from simple (= linear function without intercept term) up to 
the selected maximum. 
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Maximum rank Available for PLS regression; The maximum number of latent factors 
used to explain the variance of the data. A separate model will be 
calibrated for each rank from 1 up to the selected maximum. 

Groupwise regression Available if training samples provide categorical features; A separate 
model will be calibrated for each class of the chosen categorical 
feature. 

Validation settings 
Validation is important to validate the predictive quality of a model. In general, the kind of 
validation that can be performed depends on the provided data. PEAXACT will always calculate 
the root mean squared error of calibration (RMSEC) from the training samples. If independent 
test samples are provided, the root mean squared error of prediction (RMSEP) is calculated as 
well.  
 
Cross-validation is performed according to the options you choose in the setup dialog. Cross-
validation splits the N original training samples into two subsets, one training set to fit the 
Calibration Model and one test set to compute a validation error, and then re-partitions the 
subsets until each sample has been used for testing exactly once. The validation errors are 
averaged over the partitions to give the cross-validation error (RMSECV). 

Partitioning The kind of partitioning to be used for cross-validation: 

 None. Cross-validation is disabled (not recommended). 

 Leave-1-out. Creates N partitions by leaving out 1 sample for 
testing each time. Use for small N only! 

 K-fold. Creates k partitions by leaving out N/k samples each time. 
k=10 is a widely used standard. You can optionally choose a 
categorical feature for stratification (see below) 

 Leave-group-out. Creates partitions by leaving out 1 sample group 
for testing each time (see below). 

 K-fold groupwise. Creates k partitions by leaving out N/k sample 
groups for testing each time (see below). 

Stratification  For K-fold you can optionally choose a categorical feature for 
stratification. Stratified cross-validation creates subsets which 
roughly have the same composition of the categorical feature as the 
whole set of samples. 

Grouping For Leave-group-out and K-Fold groupwise you need to choose a 
categorical feature for grouping. Samples are treated in groups as 
defined by a categorical feature. Use this to validate across groups. 

Start calibration by clicking the OK button. 
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Calibration Results 

 
Calibration Report Window 

Results are displayed in a Report Window. The list of available reports depends on the chosen 
calibration method. 

Available Reports 

RMSE vs. Function / Rank 
RMSE values are plotted against the regression function (univariate regression) or the rank (PLS). 
RMSEC is the Root Mean Square Error of Calibration. It is the average deviation between 
predicted and actual feature values of the training samples. 

𝑅𝑀𝑆𝐸𝐶 = √
1

𝑁
∑(𝑥𝑝𝑟𝑒𝑑𝑖𝑐𝑡𝑒𝑑,𝑖 − 𝑥𝑡𝑟𝑢𝑒,𝑖)

2
𝑁

𝑖

 

RMSECV is the Root Mean Square Error of Cross-Validation. It is the average deviation between 
predicted and actual feature values when doing a cross-validation of training samples. Use this 
report to determine the regression function / rank with the least error if no independent test 
samples are available. 
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𝑅𝑀𝑆𝐸𝐶𝑉 = √
1

𝑁
∑(𝑥𝑝𝑟𝑒𝑑𝑖𝑐𝑡𝑒𝑑 𝐶𝑉,𝑖 − 𝑥𝑡𝑟𝑢𝑒,𝑖)

2
𝑛

𝑖

 

𝑥𝑝𝑟𝑒𝑑𝑖𝑐𝑡𝑒𝑑 𝐶𝑉,𝑖: calculated internally and not displayed in any report. 

 
RMSEP is the Root Mean Square Error of Prediction. It is the average deviation between predicted 
and actual feature when doing a test-set validation of independent test samples. Use this report 
to determine the regression function / rank with the least error. 

𝑅𝑀𝑆𝐸𝑃 = √
1

𝑁′
∑(𝑥𝑝𝑟𝑒𝑑𝑖𝑐𝑡𝑒𝑑,𝑖

′ − 𝑥𝑡𝑟𝑢𝑒,𝑖
′ )

2
𝑁′

𝑖

 

𝑥′: feature values of independent test samples. 
𝑁′: number of test samples. 

R2 vs. Function / Rank 
R² is the fraction of variance in 𝑥 which is explained by the Calibration Model. A value of 1 
corresponds to 100%. The plot gives an overview of R² for different regression functions / ranks. 

𝑅2 = 1 −
∑ (𝑥𝑝𝑟𝑒𝑑𝑖𝑐𝑡𝑒𝑑,𝑖 − 𝑥𝑡𝑟𝑢𝑒,𝑖)

2𝑁
𝑖

∑ (𝑥𝑡𝑟𝑢𝑒,𝑖 − 𝑥̅𝑡𝑟𝑢𝑒)
2𝑁

𝑖

 

𝑥: feature values (e.g., concentrations) of training samples. 
𝑥̅𝑡𝑟𝑢𝑒: mean 𝑥𝑡𝑟𝑢𝑒  of all training samples. 
𝑁: number of training samples. 
 
R² could be negative if the Calibration Model predicts features worse than a constant function 
would do. Obviously, such models should be discarded. 

Predicted vs. True 
Predicted feature values 𝑥𝑝𝑟𝑒𝑑𝑖𝑐𝑡𝑒𝑑  are plotted against the actual values 𝑥𝑡𝑟𝑢𝑒  for each sample. 

Samples are color-coded by their usage (green = training samples, blue = test samples, red = 
ignored samples). The plot can be used determine the predictive accuracy of the model and to 
spot feature outliers. 
 
𝑥𝑝𝑟𝑒𝑑𝑖𝑐𝑡𝑒𝑑 is calculated from samples 𝑌 using the Calibration Model 𝑓(𝑌, 𝐾). 

𝑥𝑝𝑟𝑒𝑑𝑖𝑐𝑡𝑒𝑑 = 𝑓(𝑌, 𝐾) 

The structure of function 𝑓(𝑌, 𝐾) depends on the calibration method (PI, HM, PLS) and on the 
regression settings. 
 
A best-fit line though the training points – the recovery function – is added to the chart. 

𝑥𝑟𝑒𝑐𝑜𝑣𝑒𝑟𝑒𝑑 = 𝑖𝑛𝑡𝑒𝑟𝑐𝑒𝑝𝑡 + 𝑠𝑙𝑜𝑝𝑒 ∙ 𝑥𝑡𝑟𝑢𝑒 
In case of a perfect calibration, intercept and slope of the recovery function would be zero and 
one, respectively, i.e., it would match the identity line. The deviation from the identity line can be 
used as an indicator for the predictive capability of the Calibration Model. 

Differences vs. True 
Differences between predicted and actual values are plotted for each sample. 
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𝑥𝑑𝑖𝑓𝑓𝑒𝑟𝑒𝑛𝑐𝑒 = 𝑥𝑝𝑟𝑒𝑑𝑖𝑐𝑡𝑒𝑑 − 𝑥𝑡𝑟𝑢𝑒  

Typically, differences will be distributed around zero. The plot can be used to determine shifts and 
drifts in the calibration by analyzing the distribution pattern. 
 
A dashed line – the average bias – is added to the chart. The average bias is the mean of the 
differences. 

𝑏𝑖𝑎𝑠 =
1

𝑁
∑ 𝑥𝑑𝑖𝑓𝑓𝑒𝑟𝑒𝑛𝑐𝑒,𝑖

𝑁

𝑖

 

The average bias is shown for training samples (bias C, green) and test samples (bias P, blue). It 
can be interpreted as the systematic error of prediction, i.e., predictions are off by this value on 
average. 

Predicted vs. ... 
Predicted feature values are plotted against a selectable feature. Error bars represent the 
prediction uncertainty for a 95% level of confidence. 

RMS Spectral Residuals vs. True 
RMS Spectral Residuals vs. ... 
The Root Mean Squared Spectral Residuals measure how well the model explains the spectral 
data. It can be used to spot spectral outliers. The smaller the value the better the model explains 
the spectral signal. 

𝑅𝑀𝑆 𝑅𝑒𝑠 =  √
1

𝑃
∑(𝑦𝑟𝑒𝑐𝑜𝑛𝑠𝑡𝑟𝑢𝑐𝑡𝑒𝑑,𝑖 − 𝑦𝑚𝑒𝑎𝑠𝑢𝑟𝑒𝑑,𝑖)

2
𝑃

𝑖

 

𝑦: spectral intensities. 
𝑦𝑟𝑒𝑐𝑜𝑛𝑠𝑡𝑟𝑢𝑐𝑡𝑒𝑑: spectral intensities reconstructed by the model. For HM this is the fitted Hard 
Model; for PLS it is the reconstruction using 𝑅 PLS loadings. Spectral residuals are not available 
for PI models. 
𝑃: number of spectral data points. 
𝑅: rank of the PLS model. 

Mahalanobis distance vs. True 
Mahalanobis distance vs. RMS Spectral Residuals 
Mahalanobis distance vs. ... 
The Mahalanobis Distance tells how similar a sample is to the set of training samples and can be 
used to spot spectral outliers. It is a measure of the multivariate distance from the centroid 
comprised of the PLS scores of all training samples. The Mahalanobis distance is not available for 
HM and PI models. 

𝑀𝐷𝑖 = √𝑠𝑖 ∙ (𝑆𝑇 ∙ 𝑆)−1 ∙ 𝑠𝑖
𝑇 ∙ (𝑅 − 1) 

𝑠𝑖: row vector of 𝑅 PLS scores of spectrum 𝑖 for which the MD should be calculated. 
𝑆: is the 𝑁-by-𝑅 matrix of row-wise PLS scores of all training samples. 
𝑅: PLS rank. 
𝑁: number of training samples. 
Superscript 𝑇 denotes the transposed matrix. 
Superscript −1 denotes the inverse matrix. 
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Calibration curve 
The calibration curve is the actual regression function of the Calibration Model. It can only be 
displayed for univariate calibration (HM and PI). 

𝑥𝑖 = 𝑌𝑖 ∙ 𝐾 
𝑥: features of training samples. 
𝑌𝑖: design matrix of component weights (HM) or peak areas (PI) of sample 𝑖. 
𝐾: vector of regression coefficients (calibration constants). 
Note that the regression function is linear in 𝐾, but could be nonlinear in component weights or 
peak areas depending on how the design matrix is built. For instance: 

𝑥𝑖 = [𝜔𝑖
0 𝜔𝑖

1 𝜔𝑖
2] ∙  [𝑘0 𝑘1 𝑘2]𝑇  

would be quadratic in component weights 𝜔. 
 
PEAXACT uses inverse calibration (regression of 𝑥 on 𝑌) to calculate K. It has been shown that 
inverse calibration yields more precise predictions of unknowns than classical calibration 
[Tellinghuisen2000]. 

Variable Importance in Projection (VIP) 
Variable Importance in Projection (VIP) scores estimate the importance of each spectral data 
point (variable), in the projection used in a PLS model. A data point with a VIP Score close to or 
greater than 1 (one) can be considered important. Use the plot to select spectral regions of 
importance by means of a Data Filter. Note that VIP scores are calculated before applying Data 
Filters which makes the plot suitable for interactively changing Data Filters. 

PLS Loadings 
PLS loadings allow you to examine how PLS "sees" the data; that is, how it models the original 
sample spectra by a linear combination of loadings. Typically, at higher ranks, loadings look more 
and more noisy. As the rank increases, more of the noise in the system is being modeled. Use this 
report to determine the maximum rank which does not model noise. 

𝑦𝑟𝑒𝑐𝑜𝑛𝑠𝑡𝑟𝑢𝑐𝑡𝑒𝑑,𝑖 = 𝑠𝑖 ∙ 𝐿𝑇  
𝑦𝑟𝑒𝑐𝑜𝑛𝑠𝑡𝑟𝑢𝑐𝑡𝑒𝑑,𝑖: reconstruction of spectrum 𝑖. 

𝑠𝑖: row vector of 𝑅 PLS scores of spectrum 𝑖. 
𝐿: 𝑃-by-𝑅 matrix of column-wise loadings. Loadings are calculated from training samples using 
the SIMPLS algorithm. 
𝑅: rank of the PLS model. 
𝑃: number of data points. 

PLS Regression Coefficients 
PLS regression coefficients show how each spectral data point is related to a calibrated feature 
across all PLS factors, i.e., from factor 1 to rank R. As the rank increases, more of the noise in the 
system is being modeled. Use this report to determine the maximum rank which does not model 
noise. 
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Report Customization 

 

X-Axis 
For several reports you can change the x-axis to any provided sample feature (1). See Data Table 
Editor for how to add features to samples. 

Component Selection 
Use the drop-down list (2) to display results for individual Calibration Model Components 
(features). 

Function / Rank 
Use the drop-down list (3) to display results for individual regression functions / ranks. Select 
(Current Choice) to use the function / rank that is currently selected in the Current Choice Panel 
(see below). 

Group 
In case of groupwise calibration, use the drop-down list (4) to display results for individual groups 
of the categorical feature. Select (Default) to display the combined results of all groups. 

Creating Calibration Model Alternatives 

 

The Calibration Report Window displays results of the selected Calibration Model alternative. 
Calibration Model alternatives represent separate Calibration Models which can be created and 
compared within the Report Window. 

1 

2 

3 

4 

1 2 

3 
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1) Use the drop-down list to switch between different Calibration Model alternatives. 
2) Click [+] to add a new alternative. Doing so will display the Calibration Setup Dialog again 

so that you can try out and compare different calibration settings. The new alternative will 
be added to the list (1). Click [-] to remove the currently selected alternative from the list. 

3) The table displays a summary of the currently selected Calibration Model. 

Modifying Calibration Model Alternatives 

The currently selected Calibration Model alternative can be modified step-by-step to further 
improve it. The following modifications are possible: 

• Changing the sample Usage, e.g., switch between train and test, or ignore samples from 
calibration. 

• Changing Data Filters (available for PLS only). 

Each modification step automatically triggers a re-calibration and updates the selected 
Calibration Model, i.e., a modification does not create a new alternative but changes the selected 
alternative. However, you can undo/redo all modification steps using the Undo/Redo tools from 
the toolbar. 

Changing the Sample Usage 

Enable the Selection Tool  in the toolbar and select individual samples in graphical reports. 
Right-click and select the new Usage from the context menu to trigger a re-calculation of the 
Calibration Model with the new Usage. 

 

Changing Data Filters 
In the top-right pane of the Report Window, select the feature for which you want to edit the 
Data Filter and switch to any of the following reports: 

• Variable Importance in Projection (VIP), or 
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• PLS Loadings, or 

• PLS Regression Coefficients. 

Enable the Data Filter Tool  in the toolbar. 

Note: The Data Filter Tool is only available if a Data Filter was linked to the selected 
feature during calibration setup. 

When the Data Filter Tool is enabled, the Data Filter is displayed in the graph and can be modified 
with the mouse. When a Data Filter has unsaved modifications, it is displayed in red. Otherwise it 
is displayed in black. Right-click and select Apply Changes from the context menu to trigger a re-
calculation of the Calibration Model with the changed Data Filter. Select Reset Changes if you 
want to revert all changes. 
 
If a Data Filter is assigned to more than one feature, you should check your modifications with all 
features before accepting it. As a precaution, a warning is shown when you attempt to modify a 
Data Filter that is assigned to multiple features. 

 

Undo / Redo 

Select the Undo Tool  or the Redo Tool  in the toolbar to navigate through the modification 
steps of the selected Calibration Model alternative. Each Undo/Redo action will trigger a re-
calculation of the Calibration Model to restore the model. 

Accepting a Calibration Model Alternative 

To finalize calibration, you must decide on a specific Calibration Model alternative and must 
select a specific regression function / rank for each calibrated feature. Make your choice in the 
bottom-left pane of the Report Window. 
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By clicking the OK button of the Report Window, your choice is accepted, and the Calibration 
Model is added to the active model. Any changes to the sample Usage or to Data Filters are copied 
to the main window. Unused Calibration Model alternatives will be discarded. 

3.7.5.2 Remove Calibration Model 

Menu bar: Edit Model > Calibration Model > Remove 
Context menu: Model Tree > Calibration Model Item > Remove 

Removes the Calibration Model from the active model. Removing the Calibration Model also 
removes dependent elements such as Custom Results. Note that you cannot remove single 
Calibration Model Components but only the whole model. 

3.7.5.3 View 

Menu bar: Edit Model > Calibration Model > View 
Context menu: Model Tree > Calibration Model Item > View 

You can view the results of current calibration again in the Calibration Report Window, where all 
standard reports are available. 
 
Since the calibration report is opened in “View Mode”, options that would change the Calibration 
Model are disabled. 

3.7.5.4 Rename Component 

Menu bar: Edit Model > Calibration Model > Rename Component… 
Context menu: Model Tree > Calibration Model Component Item > Rename 
Properties Panel: Click Model Tree > Calibration Model Item 

Renames the selected Calibration Model Component. A component can have any name if it is 
unique within the Calibration Model. 
 
This operation applies to after a Calibration Model has been created. To change feature names 
prior to calibration, use the Data Table Editor. 
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3.7.6 Classification Model 

The Classification Model is a sub-model that is a functional relationship between sample spectra 
and the levels (categories) of a categorical feature. The functional relationship is established by 
classification. 
 
Classification Models can be utilized for Identification. 

3.7.6.1 New Classification Model 

Toolbar  
Menu bar: Edit Model > Classification Model > New… 
Context menu: Model Tree > Classification Model Item > New… 

Creates a new Classification Model and adds it to the active model, replacing a previous 
Classification Model if any. 
 
Classification is performed with selected samples except for those with Quality set to bad. 
Samples with Usage set to train are used for training the Classification Model. Training samples 
must provide a least one categorical feature. Samples with Usage set to test are used for 
validating the Classification Model. Samples with Usage set to ignore have no effect on 
classification or validation but are still included in reports.  
 
Classification begins with a setup dialog. Results are then displayed in a Report Window where 
you can evaluate alternative Classification Models. Finally, you must choose and accept one 
alternative. 
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Classification Setup 

 

Calibration Method The algorithm to be used for classification. Depending on your 
choice, the Classification Setup Dialog changes its appearance to 
provide proper controls for each method. The following options are 
available: 

 Database Lookup. Spectra of training samples are used as a 
database against which new samples are later matched. The 
matching (or lookup) is done according to smallest Pearson distance 
(largest Pearson correlation) and returns the class name of the most 
similar database sample. 

 PCA Quadratic Discriminant Analysis (PCA-QDA). Added soon. 

 PLS Discriminant Analysis (PLS-DA). Added soon. 

Categorical Feature Use the drop-down list to select a categorical feature for which the 
model should be trained. The table shows available classes of the 
selected feature and the number of available samples with Usage = 
train, test, and ignore. 
 
For method Database Lookup, a special feature Sample Name is 
available which treats each sample as a separate class. For this to 
work, all samples must have Usage = train. 
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Classifier Settings 

Measurements A method-dependent modifier that specifies how spectra should be 
treated. The following options are available: 

 normal. Available for Database Lookup; spectra are not modified. 

 centered. Available for PC-based methods; each data point of the 
spectrum is centered at the mean of that data point across all 
training samples. 

 centered + scaled. Available for PC-based methods; data points 
are centered, followed by division of each data point by the standard 
deviation of that data point. 

Maximum rank Available for PC-based methods; The maximum number of principal 
components used for dimensional reduction of the spectra. A 
separate model will be trained for each rank from 1 up to the 
selected maximum. 

Validation settings 
Validation is important to validate the predictive quality of a model. In general, the kind of 
validation that can be performed depends on the provided data. PEAXACT will always calculate 
the misclassification rate of training samples. If independent test samples are provided, the 
misclassification rate of test samples is calculated too.  
 
Cross-validation is performed according to the options you choose during classification setup. 
Cross-validation splits the N original training samples into two subsets, one training set to train 
the Classification Model and one test set to compute a validation error, and then re-partitions the 
subsets until each sample has been used for testing exactly once. The validation errors are 
averaged over the partitions to give the misclassification rate of cross-validation. 

Partitioning The kind of partitioning to be used for cross-validation: 

 None. Cross-validation is disabled. For Database Lookup of feature 
Sample Name, this is the only option. For other methods, this is not 
recommended. 

 Leave-1-out. Creates N partitions by leaving out 1 sample for 
testing each time. Use for small N only! 

 K-fold. Creates k partitions by leaving out N/k samples each time. 
k=10 is a widely used standard. K-fold cross-validation is always 
stratified. Stratified cross-validation creates subsets which roughly 
have the same composition of the categorical feature as the whole 
set of samples. 

Start classification by clicking the OK button. 
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Classification Results 

 
Classification Report Window 

Results are displayed in a Report Window. The list of available reports depends on the chosen 
classification method. 

Available Reports 

Misclassification Rate / Error rate 
The misclassification rate (also known as error rate) is an overall measure for how often the 
Classification Model incorrectly identifies the class of a sample. It is the ratio of the number of 
incorrectly identified samples to the number of all samples. Misclassification rates can also be 
calculated separately for the set of training samples, for cross-validation, and for the set of test 
samples. 

Confusion Matrix 
A graphical visualization of the row-wise percentage of correctly identified classes (main 
diagonal) and incorrectly identified classes (off-diagonals). E.g., a perfect classification would 
have 100% values on the main diagonal. Numbers are calculated from the combined set of 
training and test samples. 
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Use the confusion matrix to inspect the performance of the Classification Model on a per-class 
basis. 

Identified Class vs … 
Identified class names are plotted against a selectable feature. In addition, samples can be 
colored by a second feature. 

Table: Confusion Matrix 
A tabular visualization of the correctly identified class counts (main diagonal) and incorrectly 
identified class counts (off-diagonals). A row-wise summary of misclassification rates is added to 
the right of the table. Numbers are calculated from the combined set of training and test samples. 

Table: Classification Details 
Table of all results per sample. 

Creating Classification Model Alternatives 

 

The Classification Report Window displays results of the selected Classification Model alternative. 
Classification Model alternatives represent separate Classification Models which can be created 
and compared within the Report Window. 

1) Use the drop-down list to switch between different Classification Model alternatives. 
2) Click [+] to add a new alternative. Doing so will display the Classification Setup Dialog 

again so that you can try out and compare different classification settings. The new 
alternative will be added to the list (1). Click [-] to remove the currently selected 
alternative from the list. 

3) The table displays a summary of the currently selected Classification Model. 

Modifying Classification Model Alternatives 

The currently selected Classification Model alternative can be modified step-by-step to further 
improve it. The following modifications are possible: 

• Changing the sample Usage, e.g., switch between train and test, or ignore samples from 
classification. 

Each modification step automatically triggers a re-classification and updates the selected 
Classification Model, i.e., a modification does not create a new alternative but changes the 
selected alternative. However, you can undo/redo all modification steps using the Undo/Redo 
tools from the toolbar. 

1 2 

3 
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Changing the Sample Usage 

Enable the Selection Tool  in the toolbar and select individual samples in graphical reports. 
Right-click and select the new Usage from the context menu to trigger a re-calculation of the 
Classification Model with the new Usage. 

Undo / Redo 

Select the Undo Tool  or the Redo Tool  in the toolbar to navigate through the modification 
steps of the selected Classification Model alternative. Each Undo/Redo action will trigger a re-
calculation of the Classification Model to restore the model. 

Accepting a Classification Alternative 

By clicking the OK button of the Report Window, the selected Classification Model is added to the 
active model. Any changes to the sample Usage are copied to the main window. Unused 
Classification Model alternatives will be discarded. 

3.7.6.2 Remove Classification Model 

Menu bar: Edit Model > Classification Model > Remove 
Context menu: Model Tree > Classification Model Item > Remove 

Removes the whole Classification Model. Removing the Classification Model also removes 
dependent elements such as Custom Results. 

3.7.6.3 View 

Menu bar: Edit Model > Classification Model > View 
Context menu: Model Tree > Classification Model Item > View 

You can view the results of the current classification again in the Classification Report Window, 
where all standard reports are available. 
 
Since the calibration report is opened in “View Mode”, options that would change the 
Classification Model are disabled. 

3.7.6.4 Rename Component 

Menu bar: Edit Model > Classification Model > Rename Component… 
Context menu: Model Tree > Classification Model Component Item > Rename 
Properties Panel: Click Model Tree > Classification Model Item 

Renames the Classification Model Component.  
 
Note: This operation applies to after a Classification Model has been created. To change feature 
names prior to classification, use the Data Table Editor. 
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3.7.7 Custom Model 

The Custom Model is a sub-model that contains any number of user-defined custom results. 
There are two kinds of custom results: 

• Results of built-in analyses: Integration, Component Fitting, Prediction, Identification.  

• Results calculated from user-defined expressions. 

Building a Custom Model typically starts with adding results of built-in analyses which then can be 
referenced in user-defined expressions. 
 
Custom Models can be utilized for Custom Analyses. 

3.7.7.1 Add Result 

Toolbar:  
Menu bar: Edit Model > Custom Results > Add… 
Context menu: Model Tree > Custom Results Item > Add… 

Adds a new Custom Result by using the dialog to specify properties of the result. 

 

Analysis The kind of analysis to be performed. This is either one of the built-in 
analyses (Integration, Component Fitting, Prediction, 
Identification) where you can pick from a list of available result 
values, or Custom, which lets you write custom expressions                to 
calculate new values.  

Returns The kind of result value to be returned by the analysis. For Custom 
you need to specify whether your custom expression will return a 
numeric value or categorical value (text). For built-in analyses you 
can pick from a list that depends on the kind of analysis. 
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Of (component) Required for built-in analyses only; A reference to the model 
component that provides the result value. Each model component 
has an internal ID to which references are linked. You can safely 
rename referenced components without breaking the reference, but 
if you remove or replace a component all references to it will be 
broken. You need to repair broken references (see Edit Result 
Definition) or remove them. 

As (name) The name of the result to be displayed in reports. Results can get any 
name if it is unique within the Custom Model. 

Click OK to add the result to the Custom Model. For results with Analysis = Custom, continue with 
writing the custom expression. 

3.7.7.2 Write Custom Expressions 

Properties Panel: Click Model Tree > Custom Result Item 

Custom Results of type Analysis = Custom consist of a user-defined custom expression. A custom 
expression represents the left-hand side of an equation  
result = custom expression. 
 
Custom expressions can be edited in the Model Properties Panel. Select a Custom Result item in 
the Model Tree Panel to show the editor. 

 

Use the editor to write a custom expression, including operators, functions, and references to 
other custom results.  
 
After modifying the custom expression, press the ENTER key to save changes.  

Note: The editor turns yellow when an expression has unsaved changes. 

Numbers and Text 

Custom Results can be configured to return either numerical values or categorical (text) values. 
Make sure that your expression evaluates to the configured type. You can use conversion 
functions NUMBER() and TEXT() to convert between types. 
 
Syntax for numeric literals: 123, 3.1415, .5, 1e03, +27, -0.9, -1.23e-45 
Syntax for text literals: "ABC", "Level 4", "1.23", "" (empty text) 
Combining numbers and text: "PI = " + TEXT(3.1415), 100 >= NUMBER("99") 
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Syntax Errors and Runtime Errors 

When pressing the ENTER key in the custom expression editor, PEAXACT perform basic syntax 
checks and displays appropriate error messages. Runtime errors on the other hand are harder to 
detect as they only occur when custom expressions are evaluated. How runtime errors are treated 
depends on the software environment where the model is executed. E.g., the PEAXACT main 
window displays an error dialog, while the PEAXACT AppServer throws an exception to be 
handled by third-party software. Therefore, make sure to test the model adequately, e.g., by 
performing a Custom Analysis to see whether all results get calculated correctly. 

Operators 

Arithmetic Operators 

x + y For numeric x and y: Add x and y. 
For categorical x and y: Concatenate text. 

x - y Subtract y from x. 

x * y Multiply x and y. 

x / y Divide x by y. 

x^y Raise x to the power of y. 

Relational Operators 

x == y Returns true (1) if x is equal to y, false (0) otherwise. 

x != y Returns true (1) if x is not equal to y, false (0) otherwise. 

x <= y Returns true (1) if x is less than or equal to y, false (0) otherwise. 

x >= y Returns true (1) if x is greater than or equal to y, false (0) otherwise. 

x < y Returns true (1) if x is less than y, false (0) otherwise. 

x > y Returns true (1) if x is greater than y, false (0) otherwise. 

Logical Operators 

x && y Returns true (1) if both x and y evaluate to true, false (0) otherwise. 

x || y Returns true (1) if either x or y evaluates to true, false (0) otherwise. 

Operator Precedence 
You can build expressions that use any combination of arithmetic, relational, and logical 
operators. Precedence levels determine the order in which expressions are evaluated. Within each 
precedence level, operators have equal precedence and are evaluated from left to right. The 
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precedence rules are shown in the list below, ordered from highest precedence level to lowest 
precedence level: 

• Parentheses () 

• Power (^) 

• Power with unary minus (^-), unary plus (^+). Although most operators work from left to 
right, the operators (^-) and (^+) work from second from the right to left. It is 
recommended that you use parentheses to explicitly specify the intended precedence of 
statements containing these operator combinations. 

• Unary plus (+), unary minus (-) 

• Multiplication (*), division (/) 

• Addition (+), subtraction (-) 

• Less than (<), less than or equal to (<=), greater than (>), greater than or equal to (>=), 
equal to (==), not equal to (!=) 

• Logical AND (&&) 

• Logical OR (||) 

The default precedence can always be overridden using parentheses. 

Functions 

Mathematical Functions 

SQRT(x) Returns the square root of a number. 

MIN(x, y) Returns the smaller of two numbers. 

MAX(x, y) Returns the larger of two numbers. 

ROUND(x) Returns x rounded to the nearest integer. 

ROUND(x, n) Returns x rounded to n significant digits. 

Logical Functions 

IF(condition, x, y) Returns x if condition evaluates to true, y otherwise. x and y must 
either both be numbers, or both be text. condition must evaluate to 
a number, where 0 is considered as false and any other value is 
considered as true. The condition can contain relational and logical 
operators, e.g.,  
IF(y == 0 || (x > 40 && x < 60), x, y)  
IF(x == "A", "valid", "invalid")  

Conversion Functions 

NUMBER(text) Converts text into a number. 

TEXT(number) Converts number into text. 
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Nested Functions 
You can build expressions that use any combination of functions. Functions can be nested, i.e., 
the input argument of a function can be another function. Within the expression, functions are 
evaluated from left to right and from inner-most to the outer function. 

References 

You can build expressions that contain references to other custom results. When the expression 
gets evaluated, references get replaced by the value of the referenced result.  
 
In the expression editor, position the cursor where you want to insert a reference. Then select the 
corresponding result from the References drop-down list. The name of the referenced result is 
displayed as blue text block. The text block behaves like regular text, i.e., it can be deleted, 
selected, copied, and pasted. However, a reference belongs to a specific model, i.e., you cannot 
copy and paste references between different models. 

Broken References 
Each custom result has an internal ID number to which references are linked. You can safely 
rename results without breaking a reference, but if you remove a result all references to it will be 
broken. Broken references are displayed in the expression editor as blue text block starting with 
#Ref followed by the last known name of the removed result. Broken references must be updated 
or removed from the expression before custom results can be evaluated. 

3.7.7.3 Edit Result Definition 

Menu bar: Edit Model > Custom Results > Edit… 
Context menu: Model Tree > Custom Results Item > Edit… 

You can change the definition of a custom result if needed, e.g., modify the kind of analysis, result 
type, referenced model component, or result name. This is done with the same dialog that was 
used when adding the result (see Add Result).  

Repairing Broken References 

Note: The section is about references used in custom results of built-in analyses. For 
references used in custom expressions, see Write Custom Expressions. 

Assume there exists a Custom Result of a built-in analysis (e.g., Analysis = Prediction) which is 
referencing a Calibration Model Component Cyclohexane. Now, when the model gets re-
calibrated, the Calibration Model gets replaced and the Custom Result refers to a component that 
does not exist anymore. The reference is broken and must be repaired. You probably want the 
Custom Result to reference a component of the new Calibration Model instead. In such case, edit 
the custom result, select the new component from the dialog, and click OK.  
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3.7.7.4 Rename Result 

Menu bar: Edit Model > Custom Results > Rename 
Context menu: Model Tree > Custom Result Item > Rename 
Properties Panel: Click Model Tree > Custom Results Item 

Renames the selected Custom Result. A Custom Results can get any name if it is unique within 
the Custom Model. 

3.7.7.5 Remove Result 

Menu bar: Edit Model > Custom Results > Remove 
Context menu: Model Tree > Custom Result Item > Remove 

Removes the selected Custom Result. Removing Custom Results may affect other Custom 
Results which depend on them. 

3.8 Analysis 

Data analysis is a process of transforming data such as to highlight and extract useful information 
that is otherwise hidden in the data. 
 
PEAXACT follows and supports the typical analysis workflow, starting with data-driven analyses 
to visualize and explore the data, followed by model-based analyses to convert measured data to 
quantities of interest. 
 
Data-driven analyses can be performed with the Data Inspector. This section is dedicated to the 
specifics of model-based analyses. 

Typical Analysis Workflow 

• Select samples In the Samples Panel that you want to analyze. Samples with Quality set 
to bad will be ignored. 

• Choose an analysis method from the Analysis menu. Method availability depends on the 
active model. E.g., to perform a prediction, the model must be calibrated. Some analyses 
do not require a model but may work better / differently if one is provided. 

• Some analyses need additional input. 

• Wait for the analysis to complete. Processing time depends on the chosen analysis 
method, on the number of selected samples, and on the performance of your computer. 

• Explore results in a Report Window. 

3.8.2 Peak Picking 

Menu bar: Analysis > Peak Picking 
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Finds local maxima (peaks) in the spectrum and displays corresponding x- and y-values. Results 
are displayed in a Report Window. 
 
Peak picking is performed for the selection in the Samples Panel, not including samples with 
Quality = Bad. A model is not required for this analysis, but if one is active, data pretreatments 
are applied. 

 

Available Reports 

Peaks 
Positions of peaks plotted (in red) into chart of selected sample (black) 

Report Table 
Table with numeric values of peak positions and peak intensities 

Report Customization 

Peak Detection Limit 
Move the slider (1) up and down to increase and decrease the detection limit of peaks. 

Sample Selection 
The report shows results for a single sample at a time. Select the visible sample from the drop-
down list (2). 

1 

2 

3 
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Peak Selection 
By default, all detected peaks are shown in the graphical and tabular report. Use the list (3) to 
select and show specific peaks only. 

Edit Peak Label 
Left-click on the red peak label to start editing. Note that labels will be reset each time you 
change the peak detection limit, the sample, or the peak selection. 

 

3.8.3 MCR-ALS 

Menu bar: Analysis > MCR-ALS > Component Number Analysis 
Menu bar: Analysis > MCR-ALS > Component Analysis 

Multivariate Curve Resolution (MCR) Alternating Least Squares (ALS) intends the recovery of the 
pure response profiles (spectra, pH profiles, time profiles, elution profiles ...) of the chemical 
constituents or species of an unresolved mixture when no prior information is available about the 
nature and composition of these mixtures. 
 
MCR is performed for the selection in the Samples Panel, not including samples with Quality = 
Bad. A model is not required for this analysis, but if one is active, data pretreatments are applied. 

The Bilinear Model of MCR 

MCR requires the experimental data to be explained reasonably well by a bilinear model using a 
limited number of components. The MCR bilinear model is usually written down as 𝐷 = 𝐶𝑆𝑇, 
where 𝐷 is the spectroscopic data matrix, and 𝑆𝑇  and 𝐶 are the matrices of the pure spectra and 
the related concentration profiles for each of the compounds (contributions) in the system. 𝐶 and 
𝑆𝑇  are the small matrices of the bilinear model that contain profiles of the pure contributions 
(species, compounds) of the original data matrix and may change chemical meaning depending 
on the nature of the data 
 
MCR-ALS is an algorithm that solves the MCR basic bilinear model using a constrained 
Alternating Least Squares algorithm. The constraints used to improve the interpretability of the 
profiles in 𝐶 and 𝑆𝑇  may respond to chemical properties of these profiles (e.g., non-negativity, 
unimodality, closure ...) or have a mathematical origin (e.g., local rank and selective windows, 
trilinear structure ...). The ‘art’ and expertise in using MCR-ALS stems from the proper selection 
and application of the constraints that are really fulfilled by the data. 
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3.8.3.2 Component Number Analysis 

Menu bar: Analysis > MCR-ALS > Component Number Analysis 

Estimates the number of unknown mixture constituents by means of different figures of merit. 
Results are displayed in a Report Window. 

Available Reports 

Explained Variance 
Each component contributes to explaining the variance of the data matrix. The most likely 
number of components is reached when the next component does not significantly increase the 
explained variance anymore. 

RMS Residuals of PC Reconstruction 
A principal component analysis (PCA) is performed and then an assessment is made of how well 
each number of principal components (PCs) reconstructs the original data matrix by averaging 
the RMS residuals across all samples. The most likely number is reached when the next 
component does not significantly reduce the average RMS residuals anymore. 

Ratios 
The ratios plot supplements the Average-RMS-residuals-plot and the Variances-plot by showing 
the ratios of two successive RMS-values and variances, respectively. The most likely number of 
components is indicated by a large ratio. 

PCA Scores 
PCA scores can be interpreted as abstract component concentration profiles. Assuming the data 
matrix originates from an experiment with smooth concentration profiles, the most likely number 
of components is reached when the scores change from a smooth to a noisy profile. 

PCA Loadings 
PCA loadings can be interpreted as abstract component signal intensities. The most likely number 
of components is reached when the loadings change from a smooth to a noisy profile. 

Factor Indicator Function 
The factor indicator function reaches a minimum where the correct number of 
factors/components is expected. However, this only occurs when the error is random and uniform 
throughout the entire data. [E. R. Malinowski, Analytical Chemistry, Vol. 49 (4), April 1977]. In real 
cases, the function is typically L-shaped for about the first 10 components and the most likely 
number of components is indicated by a sharp bend in the curve. 

3.8.3.3 Component Analysis 

Menu bar: Analysis > MCR-ALS > Component Analysis 

Identifies unknown component spectra and component concentrations from a set of mixture 
spectra. Results are displayed in a Report Window. Additional input is required for this analysis. 
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Setup 

 

Number of components The number of components to be identified. Changing the number 
will adjust the table of component-specific constraints (see below) to 
the same number of rows. 

Initialization The initialization of component spectra or concentrations. 

 Auto. Uses results from previous iterations if available or option 
Purest spectra otherwise. It is the best option in general. 

 Purest spectra. Uses least correlated mixture spectra. It is the best 
option in most cases, particularly when peaks are strongly 
overlapping. 

 Purest concentrations. Uses least correlated peak profiles. It is the 
best option when characteristic peaks exist. 

Constraints 
Optionally, you can specify constraints to improve the outcome of the analysis 

Non-negative spectra Enable this constraint if y-values of pure component spectra are 
positive. This is usually valid for spectroscopic and chromatographic 
data. However, it does not hold if you use a Pretreatment Model with 
derivatives. 
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Non-negative concentrations 
Enable this constraint if concentration values are positive. This is 
usually valid for molar or weight concentrations/fractions. 

Concentration profiles with single maximum (unimodal) 
Enable this unimodality constraint if the shape of concentration 
profile has a single maximum. This also applies to profiles which are 
monotonously increasing or decreasing. 

Sum of concentrations = 1 (closure) 
Enable this closure constraint if component concentrations sum up 
to 1. 

Per group Select a categorical feature to apply the unimodality constraint to 
samples of each group separately. E.g., this allows using samples of 
multiple experiments, each having concentration profiles with a 
single maximum. 

Component-specific constraints 
Optionally, you can specify component-specific constraints. Use the table to specify whatever 
information you have available about the components that should be identified (see Number of 
components).  

Known concentrations Select a feature from the drop-down list to use its values as known 
concentrations. Feature values may be provided for all, some, or just 
a single sample. Any available information will be exploited by MCR. 
See Data Table Editor for how to add features to samples. 

Known spectrum Select a sample from the drop-down list to use its spectrum as 
known pure component spectrum.  

Convergence 
MCR-ALS is an iterative algorithm which uses convergence options as stopping criteria: 

Show intermediate results Enable to display graphical progress of component spectra and 
concentration profiles after each iteration. 

Maximum number of iterations 
The algorithm stops after the specified number of iterations. 

Maximum number of unsuccessful attempts 
The algorithm stops after the specified number of iterations without 
progress. 

Convergence tolerance The algorithm stops when the progress between iterations is below 
the specified tolerance. 
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Available Reports 

Component Spectra 
Spectra of identified pure components 

Concentrations 
Estimated concentrations (dimensionless) 

RMS Spectral Residuals 
Euclidean mean error of identified component spectra fitted linearly to measured samples 

Table: Concentration Profiles 
Numeric values of computed concentrations 

Table: Component Spectra 
Numeric values of pure component spectra 

Report Customization 

X-axis 
By default, concentrations and RMSE values are plotted against the sample index. You can 
change the x-axis to any available sample feature. See Data Table Editor for how to add features 
to samples. 

Component Selection 
By default, plots of all pure component spectra and concentrations are shown in the graphical 
report. Use the list for selective plotting. Note that RMSE values are independent of the selected 
component. 

More Iterations 

You could conduct more iterations to improve results. When clicking More Iterations at the 
bottom of the Report Window, MCR-ALS starts again, letting you choose different constraints if 
desired, but using previous results as starting values. 

3.8.4 HMFA 

Menu bar: Analysis > HMFA > Component Number Analysis 
Menu bar: Analysis > HMFA > Component Analysis 

Hard Modeling Factor Analysis (HMFA) intends the recovery of pure component spectra and 
concentration profiles of the chemical constituents of a mixture when no prior information is 
available about the nature and composition of these mixtures. It is akin to other factor analysis 
methods, e.g., Multivariate Curve Resolution (MCR), but results are closer to physics due to the 
usage of Hard Models. 
 
HMFA is performed for the selection in the Samples Panel, not including samples with Quality = 
Bad. A Hard Model is required for this analysis. 
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The Hard Model of HMFA 

The Hard Model in HMFA is used to provide the factor analysis with as much information as 
possible about the spectral structure of the mixture. E.g., if any pure component spectrum is 
known in advance, a corresponding component should be part of the Hard Model. All remaining 
peaks belonging to unknown components should be modeled in the first Hard Model Component. 
HMFA redistributes peaks of the first Hard Model Component to new components by analyzing 
the mixture spectra and identifying peaks that belong together.  
 
If, for instance, all pure component spectra were unknown, you could initially create a Hard Model 
with all peaks contained in the first Hard Model Component and let HMFA reassign them to new 
components. 
 
The identification of unknown component spectra works well if two requirements are met: 

• The first Hard Model Component must contain all the relevant peaks. No peaks must be 
missing, because only existing peaks can be reassigned. For creating such a representative 
model, it is recommended to use a representative sample of the mixture spectra for 
modeling. 

• The mixture spectra must contain reasonable variation in the components' 
concentrations. 

Eventually, HMFA fits the new Hard Model (which now contains the newly identified components, 
and all initially provided components) to the mixture spectra to compute component weights. 
Note that this kind of component fitting differs from regular component fitting in the following 
aspects: 

• The Hard Model is fitted linearly no matter the component fitting mode specified in the 
Hard Model settings. 

• Fixed parameters are adjusted anyway. 

• The Hard Model Baseline is ignored; instead, a linear baseline is fitted. 

3.8.4.2 Component Number Analysis 

Menu bar: Analysis > HMFA > Component Number Analysis 

Estimates the number of unknown mixture constituents by means of different figures of merit. A 
Hard Model with at least 2 peaks in the first component is required for this analysis. Results are 
displayed in a Report Window. Additional input is required for this analysis. 
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Setup 

 

Components to test The maximum number of components to get tested. HMFA is 
performed for each number from 1 to the selected maximum. 

Available Reports 

Average RMS Residuals of Component Fits 
The average RMS residuals of component fits is the best indicator for determining the component 
number because it is an a-posteriori figure of merit. A-posteriori means that a model is created for 
each number of components and then an assessment is made of how well it explains the data by 
averaging the RMS residuals across all samples. The most likely number is reached when the next 
component does not significantly reduce the average RMS residuals anymore. Note that the 
diagram also displays a vertical line which is an estimate of the lower bound. 

Explained Variance 
Each component contributes to explaining the variance of the %s data matrix. The most likely 
number of components is reached when the next component does not significantly increase the 
explained variance anymore. 

Ratios 
The ratios plot supplements the Average-RMS-residuals-plot and the Variances-plot by showing 
the ratios of two successive RMS-values and variances, respectively. The most likely number of 
components is indicated by a large ratio. 

Factor Indicator Function 
The factor indicator function reaches a minimum where the correct number of 
factors/components is expected. However, this only occurs when the error is random and uniform 
throughout the entire data. [E. R. Malinowski, Analytical Chemistry, Vol. 49 (4), April 1977]. In real 
cases, the function is typically L-shaped for about the first 10 components and the most likely 
number of components is indicated by a sharp bend in the curve. 

3.8.4.3 Component Analysis 

Menu bar: Analysis > HMFA > Component Analysis 

Identifies unknown component spectra (if any) and component concentrations from a set of 
mixture spectra. Results are displayed in a Report Window. Additional input is required for this 
analysis. 
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Setup 

 

Number of unknown components 
The number of components to be identified. The following options 
are possible: 

 Integer >= 1. Available if the Hard Model's first component 
contains peaks. The selected number of components will be 
identified. 

 Auto. Available if the Hard Model’s first component contains peaks 
tagged as Distinctive (for HMFA). A separate component will be 
identified for each distinctive peak, using the distinctive peak as a 
reference peak. 

 

 0 (Zero). Available as the only option if the Hard Model’s first 
component does not contain peaks. No unknown components can 
be identified in this case. HMFA will simply perform a linear fit of all 
Hard Model Components. 

Mass balance The option for post-processing of calculated component weights: 

 None. Computed component weights are not processed any further. 

 Normalization. For each sample separately, computed component 
weights are normalized such that the sum of weights will be one. 
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 Optimization. For all samples simultaneously, computed component 
weights are multiplied by common factors which are found by 
numerical optimization. Again, the sum of weights will be one for 
each sample. 

Available Reports 

Component Spectra 
Spectra of all identified pure components (if any) and all initially provided pure components (if 
any) 

Concentrations 
Calculated component weights processed according to chosen closure constraint. If no closure 
constraint is applied, these values are in fact component weights. Otherwise, values represent 
dimensionless concentrations. 

RMS Spectral Residuals 
Euclidean mean of differences between fitted model and measured samples 

Table: Concentration Profiles 
Numeric values of computed concentrations 

Table: Component Spectra 
Numeric values of pure component spectra 

Report Customization 

X-axis 
By default, concentrations and RMSE values are plotted against the sample index. You can 
change the x-axis to any available sample feature. See Data Table Editor for how to add features 
to samples. 

Component Selection 
By default, plots of all pure component spectra and concentrations are shown in the graphical 
report. Use the list for selective plotting. Note that RMSE values are independent of the selected 
component. 

Create Hard Model 

If at least one unknown component gets identified, you can export the components as a new Hard 
Model. Clicking the Create Hard Model button adds a new Hard Model to the Model Tree Panel 
which contains all identified components. 

3.8.5 Integration 

Menu bar: Analysis > Integration 
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Calculates component areas by numerical integration of spectra. Results are displayed in a Report 
Window. 
 
Integration is performed for the selection in the Samples Panel, not including samples with 
Quality = Bad. An Integration Model is required for this analysis. 

Available Reports 

Peak Area 
Calculated peak areas 

Report Table 
Table with numeric peak areas 

Report Customization 

X-axis 
By default, peak areas are plotted against the sample index. You can change the x-axis to any 
available sample feature. See Data Table Editor for how to add features to samples. 

Component Selection 
By default, plots of all Integration Model Components are shown in the graphical report. Use the 
list for selective plotting. 

3.8.6 Component Fitting 

Menu bar: Analysis > Component Fitting 

Calculates component weights and other figures of merit by fitting a Hard Model to sample 
spectra. Component fitting is performed according to the specifications of the Hard Model. 
Results are displayed in a Report Window. 
 
Component fitting is performed for the selection in the Samples Panel, not including samples 
with Quality = Bad. A Hard Model is required for this analysis. 
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Available Reports 

Component Weight 
Calculated component weights 

Component Area 
Calculated component areas. Whether this report is available depends on preferences. 

RMS Spectral Residuals 
Euclidean mean of differences between fitted model and measured samples 

Table: Component Report 
Table with numeric component weights, component areas, and RMSE values. Whether or not the 
report contains component areas depends on preferences. 

Table: Parameter Report 
Table with numeric values of all parameters of all Component Fits 

Report Customization 

X-axis 
By default, component weights and RMSE values are plotted against the sample index. You can 
change the x-axis to any available sample feature. See Data Table Editor for how to add features 
to samples. 
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Component Selection 
By default, plots of all Hard Model Components are shown in the graphical report. Use the list for 
selective plotting. Note that RMSE values are independent of the selected component. 

Component Fit Preview 

Toolbar:  (preview linear Component Fit) 
Menu bar: Analysis > Manage Fits > Preview Linear Fit 
or 

Toolbar:  (preview Component Fit according to model settings) 
Menu bar: Analysis > Manage Fits > Preview Component Fit 

The Component Fit preview mode can be used to visually inspect the goodness of Component 
Fits in the main window. A Hard Model is required, and a sample must be active to enable the 
preview mode. 
 
You can either display a linear Component Fit or the actual Component Fit as specified in the 
model setting. The former one is just provided for a quick preview; the latter is the important one 
and is typically referred to when speaking of Component Fits. 
 
When the Component Fit preview mode is enabled, the Properties Panel displays properties of 
the Component Fit instead of the original Hard Model and the Plot Panel shows the Component 
Fit, i.e., the fit of the original Hard Model to the active sample. 

Note: Some model parameters cannot be modified while in preview mode. 

Managing Component Fits 

Since component fitting could be a time-consuming operation, calculated fits will be stored in 
memory. All samples having Component Fits available are labeled with [C] in the Samples Panel. 
When the preview mode is enabled, a new Component Fit will be computed automatically for the 
active sample if none exists. 
 
Component Fits will be removed from memory, when 

• modifying the Hard Model. 

• removing fits manually via menu Analysis > Manage Fits > Remove … 

• shutting down PEAXACT. You could save the session to preserve all Component Fits for 
the next time. 

Component Fits can be stored permanently, when 

• saving the session 

• exporting the current Component Fit as new Hard Model to a model file via menu Analysis 
> Manage Fits > Export Visible Fit as New Model… 
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3.8.7 Prediction 

Menu bar: Analysis > Prediction 

Calculates feature values and other figures of merit from spectra using a Calibration Model. 
Results are displayed in a Report Window. 
 
Prediction is performed for the selection in the Samples Panel, not including samples with 
Quality = Bad. A Calibration Model is required for this analysis. 

Available Reports 

Predicted Feature 
Predicted feature values are plotted against a selectable feature. Error bars represent the 
prediction uncertainty for a 95% level of confidence. 

RMS Spectral Residuals 
The Root Mean Squared Spectral Residuals measure how well the model explains the spectral 
data. RMSE values are only shown for samples for which reference values are provided. See also 
calibration reports. 

Mahalanobis distance 
The Mahalanobis Distance tells how well a sample matches the training samples used for 
calibration. The Mahalanobis Distance can be used to spot spectral outliers. See also calibration 
reports. 

Report Table 
Table with numeric values of predicted features. 

Report Customization 

X-axis 
By default, predicted features are plotted against the sample index. You can change the x-axis to 
any provided sample feature. See Data Table Editor for how to add features to samples. 

Component Selection 
By default, plots of all Calibration Model Components (features) are shown in the graphical 
report. Use the list for selective plotting. 

Command Line Alternative 

Predictions can also be started from the command line with option -predict. This has advantages 
over the graphical user interface: 

• Simultaneous analysis with multiple models 

• Results of all models are combined in a single report file 

• Results will not be lost in case of a system crash 

• Less memory-intensive 

• Suited for analyzing many samples 
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Predictions are performed for all loaded samples using all opened calibrated models. To load 
models and samples from the command line, you could: 

• save a session file in advance which contains all your necessary models and samples; then 
use command line options -restore or -session <file> in addition to –predict 

• load additional files directly from the command line by adding filenames to the command, 
e.g., peaxact –predict "my model.pxm" c:\data\dataTable.xls 

Results are written to a spreadsheet  
%LocalAppData%\S-PACT\PEAXACT 5\Reports\<YYYY-MM-DD hh.mm.ss> Analysis.csv. 

Note: Results are written to file directly after the analysis of each sample, i.e., results 
will not get lost in case of a system crash. 

See also: Command Line Options 

3.8.8 Validation 

Menu bar: Analysis > Validation 

Calculates feature values and other figures of merit from spectra using a Calibration Model and 
compares predicted values with available reference values. Results are displayed in a Report 
Window.  
 
Validation is performed for the selection in the Samples Panel, not including samples with Quality 
= Bad. A Calibration Model is required for this analysis. Selected samples should (but do not have 
to) provide values for calibrated features which could be used as reference values for quantitative 
validation of the model's predictive capabilities. 
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The Validation Report Window displays values from three different sources: 

• Predicted feature values of selected samples. Values are shown independently for each 
feature (and for each group in case of a groupwise calibration/prediction), i.e., each 
feature (and group) can be validated separately. 

• Reference values of selected samples. See Data Table Editor for how to add features to 
samples. 

• Reference values of training samples used during calibration. This is useful for comparing 
newly predicted values with original training data. 

Available Reports 

Predicted vs. True 
Predicted feature values are plotted against the actual values for each sample for which such 
reference value is provided. In addition, reference values used during calibration are displayed for 
comparison. 

Predicted vs. ... 
Predicted feature values are plotted against a selectable feature. Error bars represent the 
prediction uncertainty for a 95% level of confidence. In addition, for each sample for which 
reference values are provided, a marker represents the actual value, and differences between 
predicted and actual values are shown in a second graph. 
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RMS Spectral Residuals vs. True 
RMS Spectral Residuals vs. ... 
The Root Mean Squared Spectral Residuals measure how well the model explains the spectral 
data. RMSE values are only shown for samples for which reference values are provided. See also 
calibration reports. 

Mahalanobis distance vs. True 
Mahalanobis distance vs. RMS Spectral Residuals 
Mahalanobis distance vs. ... 
The Mahalanobis Distance tells how well a sample matches the training samples used for 
calibration. The Mahalanobis Distance can be used to spot spectral outliers. See also calibration 
reports. 

Report Customization 

X-Axis 
For some reports, you can change the x-axis to any provided sample feature. See Data Table 
Editor for how to add features to samples. 

Component Selection 
Use the drop-down list to display results for individual Calibration Model Components (features). 

Group 
Use the drop-down list to display results for individual groups (available for groupwise 
calibration/prediction only). 

3.8.9 Identification 

Menu bar: Analysis > Identification 

Calculates feature classes and other figures of merit from spectra using a Classification Model. 
Results are displayed in a Report Window. 
 
Identification is performed for the selection in the Samples Panel, not including samples with 
Quality = Bad. A Classification Model is required for this analysis. 

Available Reports 

Identified Class 
Identified classes. 

Report Table 
Table with identified class names and class probabilities. 

Report Customization 

X-axis 
By default, identified classes are plotted against the sample index. You can change the x-axis to 
any available sample feature. See Data Table Editor for how to add features to samples. 
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3.8.10 Custom 

Menu bar: Analysis > Custom 

Calculates custom results from spectra using a Custom Model. Results are displayed in a Report 
Window. 
 
The analysis is performed for the selection in the Samples Panel, not including samples with 
Quality = Bad. A Custom Model is required for this analysis. 

Available Reports 

Numerical Results 
Values of numerical custom results. 

Report Table 
Table of all Custom Results (numerical and categorical). 

Report Customization 

X-axis 
By default, calculated values are plotted against the sample index. You can change the x-axis to 
any available sample feature. See Data Table Editor for how to add features to samples. 

3.9 Preferences 
3.9.1 Preferences Editor 

Menu bar: File > Preferences 

Toolbar:   
Status bar: Left-click on session profile name 

Use the Preferences Editor to adjust PEAXACT settings. 
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Preferences Editor 

1) Select a category 
2) Edit preferences of selected category 
3) Apply changes and close dialog 
4) Discard changes and close dialog 
5) Apply changes without closing the dialog 

Changing Preferences 

Choose a category from the list (1) and then change preferences using the controls in the right 
pane (2). Click the OK (3) or Apply (5) button to accept changes; click the Cancel (4) button to 
discard changes. 

1 2 

3 4 5 
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Changing the Session Profile 

 

6) Session preferences 
7) Select a session profile 
8) Information about the profile 
9) More options for resetting, saving, or deleting the profile 

Session-related preferences are stored in profiles. There are several profiles for different purposes 
but only one profile can be active at a time. 
 
After selecting the Session category (6) use the drop-down list (7) to select a profile and load its 
preferences into the editor. Click the OK or Apply button to accept the loaded session 
preferences. 
 
Change session preferences using the controls in the right pane. The info bar (8) tells you when 
the current session profile has changes. If you want to reset or save those changes, click button 
(9) to call up the context menu with more options. If you select another profile while the current 
one has changes, you will be asked whether you want to save changes first. 

Note: You do not have to save profile changes. It is enough to click the OK button to 
accept all changes. 

Reset, Save, Create, or Delete Session Profile 

Click the button (9) to call up the context menu with more options for the current session profile: 

Reset to Last Saved State Reload the profile from its file 

6 7 9 
8 
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Reset to Factory Defaults Available only for pre-defined profiles 

Save as "<name>" Save changes under its current name 

Save as… Save the profile under a new name 

Delete Available only for user-created profiles 

Note: Saving a profile does not automatically accept the new preferences. You still 
must click the OK button. 

3.9.2 Application Settings 

Application Data Directory 

PEAXACT uses a special application data directory to save files at runtime. The directory cannot 
be changed, but for your convenience it is displayed in the Preferences Editor and can be opened 
in the Windows explorer by clicking the button next to the field. 

Main Window / Plot Panel 

Ignore excluded ranges for auto-scaling of y-axis 
The option to specify scaling of the y-axis. 

 Enabled. Y-axis limits are adjusted automatically to fit only the 
relevant measured signal, i.e., any signal that is not excluded.  

 Disabled. The y-axis is scaled automatically to fit the full measured 
signal. 

Allow mouse modification of excluded ranges 
Excluded ranges are displayed as gray patches in the Plot Panel. 
These patches typically overlap other plots. This option specifies the 
behavior when clicking on an excluded range patch. 

 Enabled. Excluded range patches could be modified interactively 
using the mouse. In this case it may be difficult to interactively 
modify other plots which are overlapped by patches. 

 Disabled. Excluded range patches cannot be modified interactively. 
Instead, it is easier to click and modify plots which are overlapped by 
patches. 

Show Hard Model Baseline as separate plot  

The option for how to treat the plot of the Hard Model Baseline. 
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 Enabled. A separate plot for the Hard Model Baseline is displayed in 
the Plot Panel. The plot can be used to interactively modify the 
baseline. 

 Disabled. The Hard Model Baseline is still calculated but it is not 
displayed as a plot. Instead, the baseline gets subtracted from the 
active sample and the corrected sample is displayed in the Plot 
Panel. This needs to get used to but has the advantage of the sample 
signal being shifted towards zero, which is favorable for Hard 
Modeling in case of strong baseline signals. 

Miscellaneous 

Number of model undo steps 

The number of modeling steps that can be undone. 

Auto-save session on exit This option specifies whether the current session is saved to the 
auto-save directory when exiting PEAXACT. 

 Never. The current session is not saved. 

 Ask. The user is asked whether to save the session. 

 Always. The current session is saved automatically. 

Keep latest N The number of session files to keep in the auto-save directory. Only 
the N most recently saved sessions are kept. 

3.9.3 Graphical Report Settings 

Graphics Style 

Font Style The font family, font decoration, and font size for text in graphical 
reports. 

Plot Style Options for showing/hiding the title, axis labels, axis ticks, legend (if 
any), and error bars (if any) of graphical reports. 

Export 

Image export resolution (DPI) 
This option only applies when exporting images to a file. 

 Auto. A default resolution for exporting graphical reports to file. The 
actual value depends on the output file format. 
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 72, 100, 150, 200, 300, 600. A fixed resolution (in dots per inch) 
for exporting graphical reports to a file. A larger value improves 
image quality, but also increases file size. 

Image export to clipboard This option only applies when copying images to the clipboard. 

 Rendered. Graphical reports are copied as raster images (bitmaps).  

 Vector. Graphical reports are copied as vector images. 

3.9.4 Table Report Settings 

Table Style 

General report information at the top 
The option to include general information in table reports. 

 Enabled. Tabular reports start with a few rows containing general 
information like the report creation time or the model file the 
analysis is based on (if any). 

 Disabled. The report consists of analysis results only. 

Include sample features The option to include sample features in table reports. 

 Enabled. The report's result table is expanded to the right to also 
include all available features of the samples being analyzed. 

 Disabled. The report consists of analysis results only. 

Timestamp first The option to include sample timestamps at the beginning of table 
reports. 

 Enabled. Timestamp values are treated in a special way and, if 
available, are added as first column to the left of result values. 

 Disabled. Timestamp values are treated like other feature values. 

Export 

Delimiter character for CSV files 
The character to be used as delimiter when saving comma separated 
value (CSV) files. 
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3.9.5 Session Settings 

Sample 

Sample X-Axis The label for the independent x-variable of the sample signal; may 
contain simple TeX expressions. 

Sample Y-Axis The label for the dependent y-variable of the sample signal; may 
contain simple TeX expressions. 

Reversed The option to specify the direction of the x-axis. 

 Enabled. The sample x-axis is displayed reversed (right-to-left). This 
is characteristic for spectra. 

 Disabled. The sample x-axis is displayed normally (left-to-right). 
This is characteristic for chromatograms and NMR FID signals. 

Default OPUS file block The filter for data blocks read from Bruker OPUS files. If the file does 
not contain the default block all blocks get loaded instead. 

Miscellaneous 

Calculate areas of Hard Model Components 
The option to specify whether Hard Model Component areas should 
be calculated. 

 Enabled. For Hard Models, the contribution of components to a 
mixture is typically expressed in terms of component weights 
(relative component areas). When this option is enabled, absolute 
component areas are calculated in addition to component weights 
and displayed next to weights in reports. 

 Disabled. No calculation of Hard Model Component areas. 

Pretreatment Defaults 

Pretreatment defaults represent default settings for new models. Whenever a new model is 
created, its Pretreatment Model gets initialized with values taken from the then-current session 
profile. For a description of individual settings, see Pretreatment Model. 

Hard Model Defaults 

Hard Model defaults represent default settings for new Hard Models. Whenever a new Hard 
Model is created, its settings get initialized with values taken from the then-current session 
profile. For a description of individual settings, see Settings for Hard Model Fitting. 
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3.10 License Management 

Menu bar: Help > Licensing… 

Use the License Activation Dialog to change your license if required (see License Activation). The 
License Activation Dialog also displays information about the current license. 

3.11 Technical Support 
3.11.1 Request Support 

Menu bar: Help > Request Support… 

Use the Support Request Dialog to send e-mails to S-PACT Technical Support directly from within 
PEAXACT. 

 

You may want to send support requests for different purposes, e.g.: 

• asking for help 

• reporting a bug / crash 

• suggesting new features 

• giving any kind of feedback 

In each case, provide a subject and description of the issue with which you are facing. You can 
optionally attach related files, e.g., a screenshot or a session file. When clicking the Send button, 
an e-mail is sent to support@s-pact.com, creating a new support case. If your computer is 
currently offline or uses protective methods to restrict internet access, click the Open in E-Mail 
Client button to have the mail sent by your default e-mail application. 

mailto:support@s-pact.com
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3.11.2 Share Session with Technical Support 

Menu bar:  Help > Share… 

You can share your PEAXACT session with an S-PACT support engineer to get a solution for an 
issue you are facing. 

 

Share offline Save your working session to a ZIP file which you can share then with 
Technical Support. Click Continue to create the ZIP file and open the 
Support Request Dialog to optionally create a new support case. 
 
Note: Technical Support can provide you with a secure upload link 
for large files. 

Share online Invite an S-PACT support engineer to connect to your Windows 
desktop. You can show your working session on your computer as if 
a support engineer were sitting right next to you. Click Continue to 
open the Support Request Dialog and request remote support. 
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4 TROUBLE SHOOTING 

Graphics problems 

Symptoms 
Some windows such as the main window or the Data Inspector are not displayed correctly, e.g., 
showing upside-down text, duplicated text, misplaced axes tick labels, black bars, or scrambled 
graphics. 

Cause 
Problems are related to hardware-based graphics acceleration performed by some video cards. 

Resolution 
Make sure to use the newest version of drivers for your graphics card. If the problem suddenly 
occurs after you updated the drivers, revert to a previous version of drivers. 
 
Start PEAXACT with command line option -openglfix. This forces the usage of software-based 
graphics acceleration. You should only use this command line option if you encounter graphical 
problems because software-based acceleration is typically slower than hardware-based 
acceleration. 

• Right-click the Windows Desktop and choose New > Shortcut 

• Enter 
"C:\Program Files\S-PACT\PEAXACT 5\Peaxact.exe" -openglfix   
You may need to replace the directory with the PEAXACT installation directory on your 
computer. Do not forget the double quotes. 

• Click Next and enter a shortcut name. 

• From now on start PEAXACT using the new shortcut. 

Startup error: Missing MWArray 

Symptoms 
The following error is displayed during PEAXACT startup: 
Could not load file or assembly 'MWArray, Version=2.19.0.0 […]' or one of its dependencies. 

Cause 
MWArray.dll (Version 2.19.0.0) is part of MATLAB Runtime 2019a and is in the Windows global 
assembly cache (GAC). The error occurs when the file is missing in the GAC, probably because of a 
missing or incomplete installation of MATLAB Runtime 2019a. 

Resolution 
Perform a clean installation of PEAXACT. This will also install MATLAB Runtime 2019a including 
MWArray.dll. 

• Uninstall PEAXACT 

• Uninstall MATLAB Runtime 9.6 

• Delete all remaining files from the MATLAB Runtime installation directory: 
C:\Program Files\MATLAB\Matlab Runtime\v96  

• Reboot the computer. 
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• Install PEAXACT again. 

Startup error: Type initializer for MathWorks.MATLAB 

Symptoms 
The following error is displayed during PEAXACT startup: 
The type initializer for 'MathWorks.MATLAB […]' threw an exception. 
Caused by: 
E.g.: Failed to find mclmcrrt9_6.dll required to load dotnetcli on system path […] 

Cause 
mclmcrrt9_6.dll is part of MATLAB Runtime 9.6 and is in the MATLAB Runtime installation 
directory. The file path is added to the system’s PATH variable. The error either indicates that the 
file is missing from the installation directory, or that the file path is missing from the PATH 
variable. 

Resolution 
Check whether the system’s PATH variable contains the following entry: 
C:\Program Files\MATLAB\Matlab Runtime\v96\runtime\win64  
If missing, consider adding it to the PATH variable. 

• Press [Windows Key] + R (or select start menu > Run…) 

• Type:    rundll32.exe sysdm.cpl,EditEnvironmentVariables 

This opens the editor for environment variables. 

• In the upper half of the window, double-click the variable named Path, select New, and 
add C:\Program Files\MATLAB\Matlab Runtime\v96\runtime\win64 to the list. 

Alternatively, a clean installation of PEAXACT should fix the problem. This will also install 
MATLAB Runtime 9.6 including mclmcrrt9_6.dll. 

• Uninstall PEAXACT 

• Uninstall MATLAB Runtime 9.6 

• Delete all remaining files from the MATLAB Runtime installation directory: 
C:\Program Files\MATLAB\Matlab Runtime\v96  

• Reboot the computer. 

• Install PEAXACT again. 

Startup error: MATLAB Runtime instance 

Symptoms 
The following error is displayed during PEAXACT startup: 
The MATLAB Runtime instance could not be initialized. 

Cause 1 
During startup, PEAXACT extracts files to a MATLAB Runtime cache directory defined by a 
system environment variable named MCR_CACHE_ROOT. The error occurs when files cannot be read 
from the directory, e.g., due to partially missing or corrupted files. 

Resolution 1 
Delete the cache directory: 
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• Browse to the cache directory by typing the following into the address bar of the Windows 
Explorer: 
%MCR_CACHE_ROOT%  

• Delete all files and folders within the cache directory. 

Restart PEAXACT 

Cause 2 
The error also occurs when files cannot be written to the MCR_CACHE_ROOT directory, e.g., due to 
missing write permissions. 

Resolution 2 
Consider relocating the cache directory: 

• Press [Windows Key] + R (or select start menu > Run…) 

• Enter:    rundll32.exe sysdm.cpl,EditEnvironmentVariables 

This opens the editor for environment variables. 

• In the upper half of the window, select Create…, then enter 
Variable name: MCR_CACHE_ROOT 
Variable value: %LocalAppData%\MatlabRuntime 

You may want to substitute the variable value by a different path for which you have full access 
permissions. 
Startup error 

Other Problems 

If you encounter a problem not mentioned before, try the following: 

• Start PEAXACT using the PEAXACT 5 Debugging shortcut in the PEAXACT installation 
directory C:\Program Files\S-PACT\PEAXACT 5. This enables verbose logging. 

Send the log file to support@s-pact.com and request help from Technical Support. 

mailto:support@s-pact.com


5 - LITERATURE 136 

 

S o l u t i o n s  f o r  P r o c e s s  A n a l y t i c s  &  C o n t r o l  T e c h n o l o g y  

5 LITERATURE 
Alsmeyer F, Koß H, Marquardt W (2004) Indirect spectral hard modeling for the analysis of 

reactive and interacting mixtures. Appl. Spectrosc. 58:975-985. DOI: 
10.1366/0003702041655368. 

Alsmeyer F, Marquardt W (2004) Automatic generation of peak-shaped models. Appl. Spectrosc. 
58:986-994. DOI: 10.1366/0003702041655421. 

Kriesten E, Alsmeyer F, Bardow A, Marquardt W (2008) Fully automated indirect hard modeling of 
mixture spectra. Chemom. Intell. Lab. Syst. 91:181-193. DOI: 10.1016/j.chemolab.2007.11.004. 

Kriesten E, Mayer D, Alsmeyer F, Minnich C B, Greiner L, Marquardt W (2008) Identification of 
unknown pure component spectra by indirect hard modeling. Chemom. Intell. Lab. Syst. 
93:108-119. DOI: 10.1016/j.chemolab.2008.05.002. 

Martens H, Næs T (1989) Multivariate Calibration. Wiley, New York. 

Tellinghuisen J (2000) Inverse vs. classical calibration for small data sets. Fresenius J Anal Chem 
368:585–588. DOI: 10.1007/s002160000556. 

 


	1 Quick Start
	1.1 What is PEAXACT?
	Separation to Related Software Products

	1.2 Getting Help
	User Manual
	Technical Support
	Blog

	1.3 Installation & License Activation
	1.3.1 Requirements
	1.3.2 Licensing
	License Options

	1.3.3 Installation
	Step 1: Before You Install
	Step 2: Install PEAXACT
	Step 3: After Installation

	1.3.4 License Activation
	Online Activation
	Offline Activation
	Network Activation


	1.4 Starting the PEAXACT Program
	Startup Options


	2 Input and Output Files
	2.1 Model File
	Supported File Formats for Reading
	Supported File Formats for Reading and Writing

	2.2 Sample File
	Sample URI
	Supported File Formats for Reading
	Supported File Formats for Writing

	2.3 Data Table File
	Supported File Formats for Reading and Writing
	Table Layout
	Table Format

	2.4 Session File
	Supported File Formats for Reading
	Supported File Formats for Reading and Writing
	Auto-Save

	2.5 Session Profile File
	Supported File Formats for Reading and Writing
	Profile Directory

	2.6 License File
	Supported File Formats for Reading

	2.7 Report File
	Supported File Formats for Writing
	Default Directory and Filename

	2.8 Log File
	Default File Path


	3 PEAXACT User Interface
	3.1 Main Window
	3.1.1 Menu bar
	3.1.2 Toolbar
	3.1.3 Status bar
	3.1.4 Model Tree Panel
	Selecting and Activating Models

	3.1.5 Samples Panel
	Selecting and Activating Samples

	3.1.6 Properties Panel
	Model Properties
	Sample Properties

	3.1.7 Plot Panel
	Available Graphs
	Interactive Modeling


	3.2 Working in Sessions
	3.2.1 New Session
	3.2.2 Open Session
	Drag and Drop
	Command Line Alternatives
	What is Restored from Session Files?
	Caution with Models Restored from Sessions!
	Update Missing Sample Files

	3.2.3 Save Session
	Auto-Saving
	What is Stored in Session Files?


	3.3 Model Management
	3.3.1 About Models
	What are Models?
	Modeling and Analysis
	Getting Access to Model Parameters
	Model File
	Exporting Reports

	3.3.2 New Model
	Model Name
	Initial Settings

	3.3.3 Open Model
	Drag and Drop
	Reload Open Model

	3.3.4 Close Model
	Unsaved Changes

	3.3.5 Close All
	Closing Models on Shutdown

	3.3.6 Save Model
	3.3.7 Save Model As
	Overwriting Existing Files

	3.3.8 Duplicate Model
	Using Duplicates


	3.4 Data Management
	3.4.1 About Samples
	What are Samples?
	The Sample URI
	Sample Name
	Features
	Sample File and Data Table File
	Getting Access to Samples

	3.4.2 Load Sample Files
	Drag and Drop

	3.4.3 Load Data Tables
	Drag and Drop

	3.4.4 Unload Selected Samples
	3.4.5 Unload All
	3.4.6 Save Data Table
	3.4.7 Update Missing Files
	Relocate
	Unload

	3.4.8 Edit Samples
	Edit Samples with PEAXACT
	Edit Samples with Microsoft Excel
	Common practice

	3.4.9 Sort Samples
	Sort order

	3.4.10 Create Mean Sample
	3.4.11 Create Representative Sample

	3.5 Reporting of Results
	Toolbar
	Report Selection & Customization
	Changing Report Appearance
	Editing Titles and Labels
	Positioning of Legends

	Print Preview Dialog

	3.6 Data Inspector
	Opening the Data Inspector
	Closing the Data Inspector
	3.6.2 Data Table Editor
	Sort Rows
	Filter Rows
	Re-arrange Columns
	Resize Columns
	Export Options
	Join Table
	Merge Options
	Preview

	Edit Feature Values
	Edit Selected Samples
	Edit Features

	3.6.3 Data Plotter
	Available Reports
	Report Customization
	Plot Configuration
	Data Pretreatment



	3.7 Modeling
	3.7.1 Model
	Modification
	Undo & Redo

	3.7.2 Pretreatment Model
	Transformation
	Modification of X-Values
	Modification of Y-Values
	3.7.2.2 Modify Pretreatments
	Interactive Modification of Excluded Ranges
	Interactive Modification of Rubber Band Baseline Nodes
	Interactive Modification of Reference Peak for Normalization

	3.7.2.3 Reset to Defaults
	3.7.2.4 Add Data Filter
	Adding Data Filters via Plot Panel
	Adding Data Filters via Data Filter Tool

	3.7.2.5 Rename Data Filter
	3.7.2.6 Remove Data Filter
	3.7.2.7 Modify Data Filter
	Changing Parameter Values
	Modifying Data Filters Interactively


	3.7.3 Integration Model
	3.7.3.1 Remove Integration Model
	3.7.3.2 Add Peak
	Adding Peaks via Plot Panel

	3.7.3.3 Move Peak
	3.7.3.4 Remove Peak
	3.7.3.5 Rename Component
	3.7.3.6 Remove Component
	3.7.3.7 Adjust Parameters
	Changing Parameter Values
	Modifying Peaks Interactively


	3.7.4 Hard Model
	Nomenclature
	Hard Model
	Hard Model Component
	Hard Model Peak
	Component Weight
	Peak Parameters
	Editable Component & Editable Peaks
	Model Fitting, Peak Fitting & Component Fitting

	3.7.4.2 New Hard Model
	Name of Editable Component
	New Hard Model for Active Sample
	New Hard Model If Required

	3.7.4.3 Remove Hard Model
	3.7.4.4 Add & Autofit Peaks
	3.7.4.5 Remove Selected Peaks
	3.7.4.6 New Component from Selected Peaks
	3.7.4.7 Import Components
	Drag and Drop
	Component Equilibration

	3.7.4.8 Rename Components
	3.7.4.9 Remove Components
	3.7.4.10 Export Components
	Overwriting Existing Files

	3.7.4.11 Adjust Parameters Manually
	Changing Parameter Values
	Fixing Parameters
	Adding Peaks
	Removing Peaks
	Modifying Peaks Interactively
	Grouping Peaks
	Switching Baseline Polynomial between Linear and Quadratic
	Modifying Baseline Interactively

	3.7.4.12 Adjust Parameters Automatically
	Peak Fitting
	Component Fitting
	Repeated Model Fitting

	3.7.4.13 Settings for Hard Model Fitting
	Peak Fitting
	Absolute Parameter Constraints

	Component Fitting
	Relative Parameter Constraints

	Optimizer Options
	Linear Fitting
	Nonlinear Fitting
	Modification
	Reset


	3.7.5 Calibration Model
	3.7.5.1 New Calibration Model
	Calibration Setup
	Regression Settings
	Validation settings

	Calibration Results
	Available Reports
	RMSE vs. Function / Rank
	R2 vs. Function / Rank
	Predicted vs. True
	Differences vs. True
	Predicted vs. ...
	RMS Spectral Residuals vs. True RMS Spectral Residuals vs. ...
	Mahalanobis distance vs. True Mahalanobis distance vs. RMS Spectral Residuals Mahalanobis distance vs. ...
	Calibration curve
	Variable Importance in Projection (VIP)
	PLS Loadings
	PLS Regression Coefficients

	Report Customization
	X-Axis
	Component Selection
	Function / Rank
	Group

	Creating Calibration Model Alternatives
	Modifying Calibration Model Alternatives
	Changing the Sample Usage
	Changing Data Filters
	Undo / Redo

	Accepting a Calibration Model Alternative

	3.7.5.2 Remove Calibration Model
	3.7.5.3 View
	3.7.5.4 Rename Component

	3.7.6 Classification Model
	3.7.6.1 New Classification Model
	Classification Setup
	Classifier Settings
	Validation settings

	Classification Results
	Available Reports
	Misclassification Rate / Error rate
	Confusion Matrix
	Identified Class vs …
	Table: Confusion Matrix
	Table: Classification Details

	Creating Classification Model Alternatives
	Modifying Classification Model Alternatives
	Changing the Sample Usage
	Undo / Redo

	Accepting a Classification Alternative

	3.7.6.2 Remove Classification Model
	3.7.6.3 View
	3.7.6.4 Rename Component

	3.7.7 Custom Model
	3.7.7.1 Add Result
	3.7.7.2 Write Custom Expressions
	Numbers and Text
	Syntax Errors and Runtime Errors
	Operators
	Arithmetic Operators
	Relational Operators
	Logical Operators
	Operator Precedence

	Functions
	Mathematical Functions
	Logical Functions
	Conversion Functions
	Nested Functions

	References
	Broken References


	3.7.7.3 Edit Result Definition
	Repairing Broken References

	3.7.7.4 Rename Result
	3.7.7.5 Remove Result


	3.8 Analysis
	Typical Analysis Workflow
	3.8.2 Peak Picking
	Available Reports
	Peaks
	Report Table

	Report Customization
	Peak Detection Limit
	Sample Selection
	Peak Selection
	Edit Peak Label


	3.8.3 MCR-ALS
	The Bilinear Model of MCR
	3.8.3.2 Component Number Analysis
	Available Reports
	Explained Variance
	RMS Residuals of PC Reconstruction
	Ratios
	PCA Scores
	PCA Loadings
	Factor Indicator Function


	3.8.3.3 Component Analysis
	Setup
	Constraints
	Component-specific constraints
	Convergence

	Available Reports
	Component Spectra
	Concentrations
	RMS Spectral Residuals
	Table: Concentration Profiles
	Table: Component Spectra

	Report Customization
	X-axis
	Component Selection

	More Iterations


	3.8.4 HMFA
	The Hard Model of HMFA
	3.8.4.2 Component Number Analysis
	Setup
	Available Reports
	Average RMS Residuals of Component Fits
	Explained Variance
	Ratios
	Factor Indicator Function


	3.8.4.3 Component Analysis
	Setup
	Available Reports
	Component Spectra
	Concentrations
	RMS Spectral Residuals
	Table: Concentration Profiles
	Table: Component Spectra

	Report Customization
	X-axis
	Component Selection

	Create Hard Model


	3.8.5 Integration
	Available Reports
	Peak Area
	Report Table

	Report Customization
	X-axis
	Component Selection


	3.8.6 Component Fitting
	Available Reports
	Component Weight
	Component Area
	RMS Spectral Residuals
	Table: Component Report
	Table: Parameter Report

	Report Customization
	X-axis
	Component Selection

	Component Fit Preview
	Managing Component Fits

	3.8.7 Prediction
	Available Reports
	Predicted Feature
	RMS Spectral Residuals
	Mahalanobis distance
	Report Table

	Report Customization
	X-axis
	Component Selection

	Command Line Alternative

	3.8.8 Validation
	Available Reports
	Predicted vs. True
	Predicted vs. ...
	RMS Spectral Residuals vs. True RMS Spectral Residuals vs. ...
	Mahalanobis distance vs. True Mahalanobis distance vs. RMS Spectral Residuals Mahalanobis distance vs. ...

	Report Customization
	X-Axis
	Component Selection
	Group


	3.8.9 Identification
	Available Reports
	Identified Class
	Report Table

	Report Customization
	X-axis


	3.8.10 Custom
	Available Reports
	Numerical Results
	Report Table

	Report Customization
	X-axis



	3.9 Preferences
	3.9.1 Preferences Editor
	Changing Preferences
	Changing the Session Profile
	Reset, Save, Create, or Delete Session Profile

	3.9.2 Application Settings
	Application Data Directory
	Main Window / Plot Panel
	Miscellaneous

	3.9.3 Graphical Report Settings
	Graphics Style
	Export

	3.9.4 Table Report Settings
	Table Style
	Export

	3.9.5 Session Settings
	Sample
	Miscellaneous
	Pretreatment Defaults
	Hard Model Defaults


	3.10 License Management
	3.11 Technical Support
	3.11.1 Request Support
	3.11.2 Share Session with Technical Support


	4 Trouble Shooting
	Graphics problems
	Symptoms
	Cause
	Resolution

	Startup error: Missing MWArray
	Symptoms
	Cause
	Resolution

	Startup error: Type initializer for MathWorks.MATLAB
	Symptoms
	Cause
	Resolution

	Startup error: MATLAB Runtime instance
	Symptoms
	Cause 1
	Resolution 1
	Cause 2
	Resolution 2

	Other Problems

	5 Literature

